Android devices slow on WiFi?

Jandresen
New here

Android devices slow on WiFi?

I've noticed my Android devices getting reeeally slow on my MR33 APs. 

When I look in the settings menu the network speed is sometimes dipping down to 96kbps and sometimes at 325mbps. 


I've tried switching to Dualband without band steering, Channel is set to automatic.


The issue is both LAN and WAN when it happens. Wired connections are fine.

 

What are some things I can try on my MR33 when I notice my android devices are performing slowly? 

11 REPLIES 11
PhilipDAth
Kind of a big deal

Disable 2.4Ghz.

PhilipDAth
Kind of a big deal

User 25.13 firmware.

 

Check out Wireless/RF Spectrum and make sure there is plenty of free spectrum.

Check out Wireless/Wireless Health and see if it says anything interesting.

 

You could also take a look at Wireless/Air Marshall, but it doesn't sound like a security issue to me.

thanks Phillip I'll do that when it happens again

I would turn 2.4Ghz off now.  It is nothing but a pain.

MarcP
Head in the Cloud

Have got the same Problem, but it doesn´t matter if I use Dual Band, only 5 GHz or only 2,4GHz (activated option by support).

 

My phone is also disconnecting from the WiFi several times a day. But as it is only one Android device (iphones and other Androids work fine)

So, you may have this problem only at this device as well?

degarris
Here to help

I have basically the same issue, my Samsung Android phone gets speeds over 200 MBPS when connected to home wifi, however when I connect it to Meraki MR18, it drops to 5 MBPS. I connect my laptop to Meraki AP and it is up to 200. Doesn't make sense, not the phone or wouldn't get high speeds on home router. Tried several suggestions from opening a case online from support, none fixed it including downgrading firmware to 25.

Bossnine
Building a reputation

Maybe not related at all, but we have some Android powered Promethean boards here that absolutely will not work well on the 40Mhz channel width.  If I switch the 20 they work perfectly, regardless of the fact that the documentation states it works on 20/40/80. 

 

And it seems to be just with Meraki APs.

Today I checked again the speeds by connecting my Android phone to the MR18 before contacting support by phone to trouble shoot as suggested by online case engineer. To my surprise I went from 5 mbps yesterday to over 60 today. Nothing has changed in the last 24 hours. I went into event log and did see this event, stating improved network performance but no actually channel change is evident.  Good news its much improved, bad news no evidence to why.

 

Channel changed to improve network performance  « hide

New_Channel100/40
Old_Channel100/40
Radio1

More testing using wife's Samsung A20 model, it also like mine connected to MR18 at slow 4 - 5 mbps, one of the suggestions by support for mine was to whitelist it, so I did the same to hers, speed still not change, as I was reviewing events, RF and channel data, and began a packet capture the speed went up to 60 mbps. Curious if the whitelist would have changed anything and this takes several minutes to take affect, or does the AP just take awhile to ramp up the connection speed ?

PhilipDAth
Kind of a big deal

>or does the AP just take awhile to ramp up the connection speed 

 

The AP - no.

The client - sometimes, especially if the battery is not fully charged.  They sometimes limit their throughput to make their battery last longer.

Very interesting, certainly didn't think of that but could make sense.....especially witnessing this first hand...thank you!

Get notified when there are additional replies to this discussion.
Welcome to the Meraki Community!
To start contributing, simply sign in with your Cisco account. If you don't yet have a Cisco account, you can sign up.