AP MR34 doesnt working with 2 VLANs (with 2 SSIDs) with Cisco TRUNK or Meraki MX TRUNK

Just browsing

AP MR34 doesnt working with 2 VLANs (with 2 SSIDs) with Cisco TRUNK or Meraki MX TRUNK

I have 2 VLANS (1 VLAN 10 is tagged with SSID GUEST) and (1 VLAN 20 untagged -native vlan- with SSID corp). Only I can connect with the VLAN 10. Meraki MR 34 has updated firmware.

This config is next:

Side Meraki MR 34: Uplink

Type Static IP
Subnet mask
Primary DNS
Side Catalyst Cisco uplink:
interface GigabitEthernet1/0/46
description WIFI-AP1
switchport trunk native vlan 20
switchport mode trunk
SW-cisco#sh mac address-table interface g1/0/45
Mac Address Table

Vlan Mac Address Type Ports
---- ----------- -------- -----
20 8815.3333 DYNAMIC Gi1/0/45
10 b49d.4444 DYNAMIC Gi1/0/45
10 b49d.5555 DYNAMIC Gi1/0/45
10 c0ee.6666 DYNAMIC Gi1/0/45
Total Mac Addresses for this criterion: 4
I have tried with the side Meraki to put VLAN 20 in the uplink but it doesnt work, this is the only way to have at least one SSID (in VLAN 10) but I need more networks and VLANs. I have tried several configs (without VLAN native 20 in cisco, etc...).
I can reach gateway, DNS, etc...
Somebody help me?
Best regards and thanks in advance


Kind of a big deal

On the Meraki side for SSID corp configuring it to bridge and choose "Don't use VLAN tagging".  Because you are using a static IP of the same subnet should be configured for VLAN20 otherwise the AP wont be able to reach the cloud.


On the Meraki side for SSID guest configuring it to bridge and choose "Use VLAN tagging" and put in a VLAN tag of 10.

Ok tanks a lot, I will try but I think that I tried that configuration....

Get notified when there are additional replies to this discussion.
Welcome to the Meraki Community!
To start contributing, simply sign in with your Cisco account. If you don't yet have a Cisco account, you can sign up.