AP Load Balancing

Comes here often

AP Load Balancing

Has anyone had any luck getting load balancing to work properly? I have a 30'x30' wide open room that gets loaded with about 80-150 devices quite often. The room an AP on each wall (MR84 each with patch antennas).


What we're seeing is that one AP will take the bulk of the devices, bog itself down to dial-up speeds and the other 3 APs will just happily sit with 5-10 clients. Instead of the clients being evenly redistributed across all the APs.

I've opened multiple tickets with support just to be told that they me to setup a Linux/Mac device in monitor mode to ensure the APs are receiving each others beacons.


At this point I'm ready to rip out all the MR APs and move on to something else.

Kind of a big deal
Kind of a big deal

Have you tried turning down the antenna power so the APs overlap less?  The clients control which AP they connect to so if they see a strong signal and a medium signal they will just stick to the first one they connected to.

Kind of a big deal

Actually, there are two things to investigate here:

1) why does the client balancing not work

2) why do most of the clients choose only one AP


1) Can the APs talk to each other on the LAN side? That is needed for distributing the client information from AP to AP. Then there are a couple of event logs for "load balancing" decisions. Do they show up, do you see load balancing decisions?

2) Did you do a validation survey to verify that you have different "best" APs in different parts of the room? Here it really could be that antenna-positioning is not optimal. Have you checked if the transmit-power of the APs are low enough?

Kind of a big deal

If there are only two APs don't turn down the power level.  Instead, increase the minimum bit rate.  If it is a single room like that I would try making the minimum bit rate 54Mb/s.


Also, two APs is not really enough for 150 clients unless they are doing VERY light Internet usage.  I would be aiming for more like 5 or 6 APs.

Kind of a big deal

I read his message that he has four APs, and with the room size, I typically would not let the AP alone decide the power level. But I assume this problem can only be solved satisfactorily with someone measuring the environment.

Kind of a big deal

I missed that bit @KarstenI .


I would still increase the minimum bit rate substantially and if possible disable 2.4Ghz spectrum and use 20Mhz wide channels.

With 4 or 5 APs there should be plenty of channels available at 20Mhz wide in the 5Ghz band, barring external interference and others users of spectrum.

I should have checked this earlier. Here are some answers:

Can the APs communicate with each other via the LAN? Yes

Have you changed the output power? No

Have you tried disabling 2.4Ghz? No

There is 4 APs in the room


I'll try changing the bit rate on the SSID and creating a new power profile, thanks for the suggestions.

Get notified when there are additional replies to this discussion.
Welcome to the Meraki Community!
To start contributing, simply sign in with your Cisco account. If you don't yet have a Cisco account, you can sign up.