MS390 OSPF uplink subnet in OSPF domain?

Toby
Getting noticed

MS390 OSPF uplink subnet in OSPF domain?

Hello!

 

I'm brand new to L3 Meraki/Meraki OSPF and have a question. I also tried reading this documentation without understanding why the thing I'm trying to do does not work:
https://documentation.meraki.com/MS/MS_Installation_Guides/MS390_Series_Installation_Guide

 

https://documentation.meraki.com/Architectures_and_Best_Practices/Cisco_Meraki_Best_Practice_Design/...

 

https://documentation.meraki.com/MS/Layer_3_Switching/MS_Layer_3_Switching_and_Routing

 

https://documentation.meraki.com/MS/Layer_3_Switching/MS_OSPF_Overview#MS_OSPF

 

 

Is it possible to set up the uplink network which the MS390 use to communicate with the cloud for participation in the OSPF routing domain?

 

I tried setting up another IP on the same subnet/VLAN under "Routing & DHCP", this newly created interface cannot reach anything, not even the mgmt IP of the MS390 itself. Is there some VRF going on under the hood? I tried this because the mgmt subnet cannot be configured for OSPF participation otherwise.

 

I'm guessing I have to set up the mgmt/cloud uplink outside of the OSPF process with the subnet terminating in a border device?

2 REPLIES 2
WirelesslyWired
Meraki Employee

Re: MS390 OSPF uplink subnet in OSPF domain?

Hey, these are good questions. Your L3 switch or switch stack will need to have it's management IP within the uplink subnet with a default gateway that is routable to the internet. This does NOT mean that it cant be in the same L3 segment, but you have to have a control plane MGMT IP & Data-plane IP. Example. 

 

Northbound uplink is 10.0.0.0/29. 

 

  • Neighbor is 10.0.0.1
  • switch SVI is 10.0.0.2 and default static is 10.0.0.1
  • switch management is 10.0.0.6 and default gateway is 10.0.0.1

You can absolutely peer with 10.0.0.1 using OSPF for dynamic routing, but the management interface (10.0.0.6) must be able to statically point to 10.0.0.1 and reach the internet. 

 

CCIEw# 45253 / CWNE# 249 / Senior Technical Marketing Engineer - Meraki MS Product
Toby
Getting noticed

Re: MS390 OSPF uplink subnet in OSPF domain?

Okay, thanks for the clarification. That why the SVI and MGMT IP cant reach each other I guess, because of the controlplane vs dataplane (I'm a bit rusty it would seem).

 

I'll have some more labbin done on this, cheers!

Welcome to the Meraki Community!
To start contributing, simply sign in with your Cisco account. If you don't yet have a Cisco account, you can sign up.