celular failover on a z1

Here to help

celular failover on a z1


I have a z1 connected to a fiber internet line. Connected to the usb port I have a Huawei E3372 CDC modem. In appliance status the z1 sees mode in ready mode. If I remove the main line, the modem will not activate the 4g connection. If I remove and reinsert it, then the connection is activated. Is it a correct behavior?



Meraki Employee

No, not the correct behavior, I would try another cellular modem if you have access to one.  Just tried it on my own Z1 with a PanTech UML295 to check the behavior.  Without the cellular modem inserted, my WAN port is in the green "Active" state and there is no Cellular state even listed.  When I stay on that Appliance Status page and plug in the cellular modem, I see a Cellular status show up under the WAN status, with a green "Connecting" status for maybe 5 to 7 seconds, followed by a green "Ready" status.   Then if I pull the cable out of the Internet port, within about 5 seconds the WAN status disappeared and the Cellular status immediately transitioned to "Active" (instead of "Ready").  I then ran some pings and traceroutes, no issues.  When reconnecting the WAN link, the WAN status transitioned to a red "Failed" status just for a couple seconds and then at the same time WAN went to "Active" and cellular went to "Ready".  Repeated this multiple times. 


If you're not seeing very similar behavior, I suspect the cellular modem may be at fault.  Double check the supported models https://documentation.meraki.com/MX-Z/Cellular/3G_-_4G_Cellular_Failover and you could also open a case with Meraki Support, they can first make sure there's not a firmware issue on the Z1 that might cause this, and they might have some lower level visibility into the logs with better info about why it's not activating when you remove the primary connection.  


I am seeing the same issue with Z1 with Telstra (Australia) U320 Aircard. Tech support was not able to resolve it and suggest I try the same with an MX64.


If I boot off the Z1 with only the USB modem, it is not able to connect to Telstra 4G.

if I boot off with both connected, they both connect fine with WAN link active and USB 4G connected.


Chasing down an MX64 to test this now. Firmware for Z1 is 13.28. Tried 12.26 too.

Getting noticed

Z3 is not even able to connect to the Telstra 4G with the same USB modem.

Get notified when there are additional replies to this discussion.
Welcome to the Meraki Community!
To start contributing, simply sign in with your Cisco account. If you don't yet have a Cisco account, you can sign up.