Setting up TFTP on MX68 to upgrade switches in LAN

Tariqmahmood
Comes here often

Setting up TFTP on MX68 to upgrade switches in LAN

I am struggling in setting up TFTP setup in Meraki.

 

HLD

multiple switches---->Cisco switch(2960) ---> Meraki (MX68) ---> vMX ---> Azure(VM with TFTP server)

                                  

Meraki configuration:

FW rules : allowed all traffic

configure --> DHCP --> VLAN1(MGMT) -->DHCP options --> Custom --> code 66 --> IP for TFTP server(azure vm private IP)

 

vMX 

no change

FW: all traffic allowed

 

Azure(VM)

installed TFTP64 software

also tried Solarwind TFTP

 

Output: Azure VM is pinagble from switch, but when trying to transfer file says no connection for tftp. any idea

 

 

 

2 REPLIES 2
PhilipDAth
Kind of a big deal

Host firewall on the TFTP server (try turning off Windows firewall)?  Azure network security group allowing TFTP?

Hi, It worked while adding rule in windows firewall 1. TFTP port and 2. TFTP application. I didnt added TFTP application rule. That's why it was not transferring.

Get notified when there are additional replies to this discussion.
Welcome to the Meraki Community!
To start contributing, simply sign in with your Cisco account. If you don't yet have a Cisco account, you can sign up.
Labels