cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 

Re-deploying vMX100 in Azure

Highlighted
Here to help

Re-deploying vMX100 in Azure

Hey guys.

We we deployed a vMX in Azure but didn't like how we architectured the solution. We decided to redeploy the VM (same day).

 

So we removed the device from the Meraki Network, deleted the managed app instance in Azure and redeployed it. We regenerated the auth token and used it during the redeployment. We have repeated this 5 times with no luck in having the dashboard seeing the instance.

 

I know the VM has an external IP and I can ping it from outside the network. I also know that the internal IP is working as I built a VM in the same vNET and was able to ping the device.

 

I have called Meraki support who have advised that we need to call the new Network something different which seems strange. No dramas. We have done this and redeployed the VM again. The VM just doesn't seem to want to register against the dashboard.

 

Support told us to wait 12 hours which seems like a duck shove to someone else so he doesn't have to deal with it. I told him that the first time we did it, the registration took 5 minutes. He is going to check back in 2 hours. 🙄

 

Does anyone have any experience with this or any ideas for us to try?

 

11 REPLIES 11
Highlighted
Kind of a big deal

Re: Re-deploying vMX100 in Azure

It doesn't take 12 hours.  It might take 10 minutes if it has to deploy a firmware update.  I have deleted and re-deployed into the same network without issue.

 

Any chance your Azure firewall rules are blocking outbound access?

 

Highlighted
Kind of a big deal

Re: Re-deploying vMX100 in Azure

Does Azure let you see the console?  If so, take a look there and see if it is reporting anything interesting.

Highlighted
Here to help

Re: Re-deploying vMX100 in Azure

Zero firewall rules and no network security groups on this vNET.

 

12 hrs felt like a support engineer trying to get rid of me 🙂

Highlighted
Here to help

Re: Re-deploying vMX100 in Azure

Unfortunately no. The resource is a managed application and there is a no boot diagnostics configured so you cannot access the console.

Highlighted
Here to help

Re: Re-deploying vMX100 in Azure

Have you tried to re-deploy without deleting the original? Put it in a diff subnet and rebuild from scratch. Once it's up delete the old and enjoy.

 

Just my two cents.

 

-Dennis

Highlighted
Here to help

Re: Re-deploying vMX100 in Azure

this is EXACTLY happening to me right now ...

 

It worked like a charm the 1st time but if you want to delete and do it again ... this is where the problems arrive

 

I have deleted EVERYTHING in Azure .... I have recreated the VNET and changed the NAME and everything but it's definitely not working ...

 

I did it before going to bed and waited 8 hours ... Didn't work 😞

 

I deleted everything this morning and still nothing (4 hours after) ... Guess I ll wait until tomorrow but this is definitely not the behavior you would expect.

 

 

Highlighted
Here to help

Re: Re-deploying vMX100 in Azure

How are you looking now? I still have an active ticket open with Meraki but the engineer says I have to contact Azure. Really getting sick of the blame game.

Highlighted
Here to help

Re: Re-deploying vMX100 in Azure

Still waiting on a feedback from Meraki ... but yeah ... it does smell bad 😕

Highlighted
Here to help

Re: Re-deploying vMX100 in Azure

So a early morning call to Meraki support got me talking to a engineer in the US. They were much helpful than the Sydney guys.

 

Basically if you don't create a new RG and vNET, it just doesn't work. We had an existing vNet that we wanted to use but had to create another one. Luckily we hadn't started using the existing vNet so we were able to leverage the Meraki created vNet and create additional Subnets for our infrastructure.

Highlighted
Here to help

Re: Re-deploying vMX100 in Azure

On my case I deleted EVERYTHING in Azure .... and started from scratch .. still no luck 😕

 

 

Highlighted
Conversationalist

Re: Re-deploying vMX100 in Azure

Guys,

 

Any fix for this.

 

Regards,

Pavithran C

Welcome to the Meraki Community!
To start contributing, simply sign in with your Cisco account. If you don't yet have a Cisco account, you can sign up.