Meraki dns issue

SOLVED
tantony
Head in the Cloud

Meraki dns issue

I’m using a MX84.  I can ping the dns server by its ip but not by its dns name. 

 

For example, I can ping 172.16.0.25, which is the dns server. It’s bostame is scaserv1, but I can’t ping it. 

 

Any my idea why?

1 ACCEPTED SOLUTION
Nash
Kind of a big deal

@tantony, how are you mapping your drives? Unless you add a WINS server (please don't) in your client VPN config on the MX, something like \\server01\files won't work. You'll need to map the drives as \\server01.domain.local\files, using the FQDN. 

View solution in original post

5 REPLIES 5
PhilipDAth
Kind of a big deal

If you are using Windows, try going to a command prompt, then run "nslookup".  Make sure it reports that it is using the correct DNS server IP address.  If the wrong IP address is reported then examine your IP configuration to see why the machine is using the wrong DNS server IP address.

 

Put the server name in.  If resolution fails then the DNS server has no entry for that name.

I think it's a user or Windows 7 issue because other people who are on VPN can connect by DNS with their Windows 10 computers.  We only have this one user using Windows 7.

tantony
Head in the Cloud

I guess it's a Windows 7 issue because when I connected to VPN on Windows 7, I could ping it by ip and dns.  But, if I try to go to folder by unc path, it won't work, only by ip.

 

I just changed the path from dns to ip address, so it's working now.

Nash
Kind of a big deal

@tantony, how are you mapping your drives? Unless you add a WINS server (please don't) in your client VPN config on the MX, something like \\server01\files won't work. You'll need to map the drives as \\server01.domain.local\files, using the FQDN. 

Cerro
New here

if you can nslookup the server by specifying your dns server(nslookup DestIPaddress DNSIPaddress) ,then this is the solution that works best for me:

 

https://www.reddit.com/r/meraki/comments/arkviy/client_vpn_and_local_dns/

We had this problem with some Win10 clients, and the only workaround we've found so far is to statically set the Interface Metric value on the VPN adapter to a lower number than the local adapter, so that it uses the DNS server set on the VPN interface for name lookups. If there's a better way to handle this, I'd love to hear it.

 

This is under the vpn adapter networking IPV4 properties advanced options. Turn off IPV6 there as well.

Get notified when there are additional replies to this discussion.
Welcome to the Meraki Community!
To start contributing, simply sign in with your Cisco account. If you don't yet have a Cisco account, you can sign up.
Labels