MX64 WAN 2 Not Allowing Router Access

IT-ME
Here to help

MX64 WAN 2 Not Allowing Router Access

Hello all.

 

I have an issue where I'm unable to access the router setup on our WAN 2 connection. We have two services running through our MX.

 

1. A broadband connection provided my our ISP, 80/20, using SOGEA and using an Openreach bridge modem, no router etc.

 

2. A 4G connection from O2 on an unlimited data plan, using a Teltonika TCR100 router, believed to be in bridge mode. 

 

I obviously can't access the Openreach box on WAN 1, but I do need to access the Teltonika on WAN 2. I think I may have an issue with my IP configuration, but would appreciate any input to help solve this.

 

Thank you in advance.

11 Replies 11
KarstenI
Kind of a big deal
Kind of a big deal

Do you want to access the IP that is also the default-route on WAN2? The easiest way is to temporary set WAN2 as the primary WAN link and then access the device. If you need continuous access you need to configure a flow preference for the WAN2 subnet over WAN2.

Hello and thanks for the reply (Merry Christmas).

 

Just had too much to eat and decided to fire up the laptop and saw your response.

 

The reason I think my IP config is not right as I'm not totally confident on what I put. As I have another router and not just a bridge, I'm pretty sure my settings are not right.

 

Are you able to guide me with this at all please? At present it does work, but come midnight, the MX shows 100% loss and then I end up having to reboot things etc.

 

I will have to visit the site and try to figure this out, so any help I can get is appreciated. We had a normal FTTC connection on WAN2 before, so I knew what to put.

 

Thank you in advance and Merry Christmas.

 

 

KarstenI
Kind of a big deal
Kind of a big deal

I assume that I am not the only one who doesn't yet understand what the problem is.Please draw a picture with all IPs and describe what works and what doesn't work.

Thanks for the reply. I don't think I'm explaining myself very well.

 

WAN1 - Works, no issues, provided with external company, using Openreach Modem (white box)

 

WAN2 - Kind of works, doesn't allow access to external modem, which is a full router and not a bridge router etc.

 

I need to know if WAN2 router needs to be set in bridge or passthrough mode? What IP address information do I input on WAN2 connection on the MX64? 

 

Currently I have set the following:

 

Type - IPV4

Configured As - Static

Status - Ready

IP Address - 192.168.0.1

Subnet - 255.255.0.0

Gateway - 192.168.5.3

DNS - 8.8.8.8,  4.4.4.4

alemabrahao
Kind of a big deal
Kind of a big deal

You can't access the services via WAN 2 because it has a private IP and you need a public IP.

 

A public IP address identifies you to the wider internet so that all the information you're searching for can find you. A private IP address is used within a private network to connect securely to other devices within that same network.

 

I am not a Cisco Meraki employee. My suggestions are based on documentation of Meraki best practices and day-to-day experience.

Please, if this post was useful, leave your kudos and mark it as solved.

Thanks for the reply.

 

I understand what your saying, but is there a reason why I can't access the router interface within the network? I have VPN access all setup and put the route on the VPN. Even if I try and access the router interface within the network, I get a time out error.

 

Also, I have to keep rebooting my MX64 as it seems the WAN2 connection stops and goes to 100% loss according to the dashboard.

ITME_0-1672064633174.png

 

ww
Kind of a big deal
Kind of a big deal

You cant put it on dhcp? If you isp does not provide dhcp then contact them what to put as ip/mask/gw on your side

IT-ME
Here to help

When you say put it on DHCP, do you mean the router on WAN2? 

 

I thought this router needed to be set with a static IP address? We can't had this back to the ISP as we have just bought the router on its own and inserted the 4G sim. 

 

The WAN IP on the 4G sim will change as it's not static, but our client does not want to pay for a static IP. 

This use to work perfectly when using a 4G dongle, but we wanted to use a better 4G device so went with the Teltonika TCR100 router.

I'm still sure this is an issue with IP addresses, internally on our setup for this. The WAN side should not matter.

 

I appreciate your help. 

KarstenI
Kind of a big deal
Kind of a big deal

Not the router, but the MX should get it's IP by DHCP from the TCR100. But first I would test the device separately to find out if the repeating loss is in the WAN or on the LAN side of the TCR100.

Thanks for the reply. I will have no choice but to head over to site tomorrow and see what's going on. I have got another Teltonika, the RUT240, set this up with another MX64 and done some tests. It seems to be working ok, but will check tomorrow and report back. 

 

Thank you.

IT-ME
Here to help

**Update**

 

I visited site today as the Teltonika failed again last night. Having swapped the Teltonika for the RUT240 model I have configured it with the following:

 

Screenshot1.jpg

The router is showing connected and ready to go in the event of a WAN1 failure. That being said, I have also configured the WAN2 settings to the following:

 

Connection Type: Direct

IPV4 Config: Auto

 

Having got the IP address of the Teltonika, 192.168.1.1, I have input a "Flow Preference" as below:

 

ITME_0-1672246763889.png

The good news is I can now see the Teltonika on the network internally using a client PC.

 

The only issue I now have, I can't access the Teltonika from the VPN. I have input the destination in the client routing page on the VPN, but the page just times out. If anyone can shed some light on this that would be great.

 

Will test the connection tonight and see if it drops. 

Get notified when there are additional replies to this discussion.