How do I fix Windows 10 VPN error 798?

New here

How do I fix Windows 10 VPN error 798?

Followed Meraki’s documentation to the letter and keep getting error 798, anyone familiar with this error code? Can’t connect properly from my Windows 10 laptop.

6 Replies 6
Building a reputation

Possible causes for this are usually

a> L2TP based VPN client (or VPN server) is behind NAT.

b> Wrong certificate or pre-shared key is set on the VPN server or client

c> Machine certificate or trusted root machine certificate is not present on the VPN server.

d> Machine Certificate on VPN Server does not have 'Server Authentication' as the EKU

Now please make sure correct certificate is used both on client and server side. In case Pre Shared Key (PSK) is used, make sure the same PSK is configured on the client and the VPN server machine.


Have you tried looking at the permissions? Under the Dial-In properties section of a user's account, the control access through remote access policy option must be checked under the Remote Access Permissions (dial-in or VPN) section.


Have you checked your port settings and protocols?  If so can you provide an example or screenshot.

Thanks, @MerakiJockey505. I actually figured out my issue after finding this article:  - My upstream firewall was blocking port 4500 outbound.


I also realized that I typed the number of the error incorrectly! It's Windows Error 789 (not 798).



Awesome find @palmtree!  Good to know I will keep that solution in mind, I've definitely run across that issue before.  I figured you were talking about the dreaded 789 when I read your post, that one is definitely a pain haha. 

MS changed some things with VPNs lately with the last few updates. I don't think MS wants anyone to use them anymore In favor of windows metro/modern/whatever they will call them next week apps. Even on some other MFRs it's been the same error. 

Hi, when trying to connect the VPN with Windows 10, I have got an error message, it cannot find a certificate that can use this extended authentication protocol (Error 798). I do not understand what do then we can mail to Windows tech Support they can provide quick help to them.

New here

I was also facing this error some time ago. But one of my friends has suggested me to contact Windows support. Now my issue has been resolved. You can also get rid of this problem. Try resolving DNS Server is not responding error.

Get notified when there are additional replies to this discussion.
Welcome to the Meraki Community!
To start contributing, simply sign in with your Cisco account. If you don't yet have a Cisco account, you can sign up.