GX20 Gateway not connecting to ISP

New here

GX20 Gateway not connecting to ISP

I am a new owner/user of Meraki Go: 1 x GX20 and 2 x GR10’s.


Having successfully completed setup earlier this week, and finally “dialed in” as of yesterday, I was pretty pleased with my new network.


This morning, my internet provider (Xfinity) had an outage in my neighborhood.  They came back online within 30 mins., and much to my chagrin, I am still not back up and running on my Meraki Go gear.


My GX20 will not reconnect to the internet the way it was prior to this morning’s outage.  I have spent hours online and on call with Xfinity, and we’ve troubleshooted everything they know how - multiple modem restarts, verification that my modem is functioning with other network gear, connected my laptop directly to the modem and get internet, etc.


FWIW: my modem is a Netgear CM1000.


I have performed multiple resets of the GX20 by unplugging, waiting several moments, and replugging back in.  I have done 2 “factory resets”, and I have unplugged all other wired connections to ensure nothing else in the network might be contributing to the issue.


Bottom line:  I’m stuck with the perpetual Orange LED status light of death.


i have been back and forth with Meraki Go support on email, but there has been no meaningful contribution toward resolution, thus far - only rudimentary troubleshooting steps, most of which I’d gone through prior to their suggesting.


Last couple of thoughts:  


  • When I called Xfinity there was an automated message stating that they’d performed “upgrades” in my area, earlier today.  Is it possible they’ve affected some change(s) that has rendered an incompatibility with my Meraki Go gear?
  • I have set my old network back up (Netgear CM1000 —> Apple Time Capsule) and it is working flawlessly, even after today’s shenanigans, so it seems this is an issue specific to Meraki Go (GX20)
  • The Meraki Go App continues to indicate that all of my gear is “offline” and has been since this morning’s outage.  I have no connectivity to any of my components whatsoever.  See screenshot, attached:






New here

I'm having the exact same issue. I just configured the GX20 while connected to the (non-Meraki) LAN. Everything was fine with solid white light. Then I moved it to its final setup with connection to the WAN router (Netgear CM500v) and I'm not having any luck connecting to the internet. When I move it back to the LAN, it connects fine. Resets, etc. haven't done anything. Adding and removing the device doesn't do anything either. Opened a ticket with Meraki. 

Meraki Go Team



So we can better assist, I have a few questions:


-Can you please let us know how your topology is setup? Is the GX directly connected to the ISP modem?

-Where are the APs connected within your topology?

-Is the ISP appliance solely a modem or a modem/router combo? Can you ensure that the modem is operating in Bridge mode?

-Have you attempted a factory reset on the Meraki GX appliance as of yet? 


For assistance and reference, I have also supplied the following KB for assistance regarding the Recommended Meraki Go Topology:




I look forward to hearing from you and assisting you. 





Meraki Go Support




Hey everyone!

I wanted to point the community to a thread I replied to on reddit:



After some in-depth troubleshooting we found that the modem was sending a DHCP NAK to the GX20 when it tried to get an IP address. The modem was holding on to an old entry for the GX20, and rebooting it cleared things up.


Tools we used to get this far:

- Assigning a static IP address, and checking the local status page



I understand this article is for an access point, but the same tools and procedure are applicable to a GX20 or any of the GS line.


I hope this helps the group out.


I had the same type of issue with the GX20 and my ISP. For some strange reason, however my ISP has their dhcp server set up and how Meraki sends out packets to make sure the internet connection is up, the GX20 did not like it one bit. I emailed support on both sides and ended up having to use a public static ip address on the GX20. I have had no issues since.