iPads commands stuck in Pending

Getting noticed

iPads commands stuck in Pending

Hello Meraki users,


I have recently discovered on our older Meraki iPads, that any command send to the iPad gets stuck in the pending state. I kept the user logged in while waiting for the commands to run. The commands I tried were:

  • Update Profile
  • Lock Device
  • Restart Device

Some of the automatic commands such as TokenUpdate or Profiles refresh do appear to progress through to Success, although some of the Profiles refresh ones do appear to remain stuck in Pending. I tried manually rebooting one of the iPads but that didn't work. Sometimes, after a period of time, the Command state changes to Cancelled.


I had to fix a non-complient issue on this group of iPads a while ago, but after wiping the iPads then, they successfully connected back in and installed the appropriate apps. These iPads have shared accounts with apple school manager. Our newer and non-shared iPads appear to be working as normal.


Kind of a big deal
Kind of a big deal

@SimonA1  when you say you kept the user logged in did you mean the device is unlocked?


Is the device on the correct wifi i.e. it hasn't joined a random open network. 


Can you run another command from the dashboard such as remote restart and is that successful?




Hi Blake,


Sometimes the iPads did lock themselves, but I didn't manually log the users out. The iPads won't have jumped to a random network.


I tried a remote restart which didn't work, but one quite interesting thing occurred though. After issuing the remote restart, I waited and refreshed the activity log every so often and ensured the iPad remained unlocked. The Restart Device command stayed in pending. After about 10 minutes of keeping the iPad unlocked, I logged the user out and back in again. The Restart Device command then changed to Cancelled, but the time stamp in which the task completed was the same as when it was issued.


In summary, the Restart Device command appeared to cancel instantly, but I had to log the user out and back in for the update to be reflected in the activity log.

I would restore a device and re-enrol it and see if that fixes the problem. 

Head in the Cloud

We had over 7 iPads go offline today, maintained their WiFi but no MDM connectivity. Worse is that they are stuck in their Kiosk Application.


I have farmed them back to our base to investigate further - Something is not right. No network changes took place today or overnight. Just no connectivity. Meraki Access Points too.


Reached out to support but their advice was to factory reset them.

Get notified when there are additional replies to this discussion.
Welcome to the Meraki Community!
To start contributing, simply sign in with your Cisco account. If you don't yet have a Cisco account, you can sign up.