Your administrator has not given you access to this item.

Here to help

Your administrator has not given you access to this item.

I can no longer install new apps on AFW-deployed tablets. The apps appear under the "managed apps" in the "meraki SM"-app, but when I click on them I get redirected to Google Play Store where the following message appears : "Your administrator has not given you access to this item."

27 Replies 27
Getting noticed

Have you approved it on the app page? (see picture)Meraki.JPG
































Also, I think when I first set up our apps in SM I had to approve them on the admin account through Play Store in order for them to install

Yes I have approved the app.

When I log into the Play Store with our admin account I can see that the app is approved.


I've just deployed the app to another tablet without any problems, seems to be a problem with the SM-app on the affected tablet. I guess I will have to go for a factory reset.


I am having the same issue on our Samsung Galaxy S3's using Android 7. Newly deployed tablets.

Here to help

Yesterday I did a factory reset of the affected tablet and redeployed the device to Meraki SM.
Afterwards all of my apps installed without any problems.


Today I tried to install another app to this device and the problem reappeared...

Here to help

I'm experiencing the same issue. Factory resets have NOT helped the situation. This is a far cry from when everything goes smoothly and easily.


I've been having this issue since implementing the Meraki MDM, I opened a case with Meraki on 04/06/2018 in reference to this and, to date, nothing has been resolved. Only seems to effect Android devices, iOS devices work fine. The only work-around is to wipe the device and re-configuring it. This is very time consuming and frustrating, especially since we have employees all over the United States.


-We're using Samsung Galaxy S7s and S8s, running Android 8.0 with all updates applied, configured in AFW mode.


I was about to dump the Meraki MDM all together but we're too ingrained in their eco-system, so I've moved away from Android and am only deploying iOS devices. I am holding all purchases of Meraki equipment until this issue is resolved.


Here to help

I wonder if anyone of the Cisco/Meraki staff ever read these posts

I don't think anyone form Meraki monitors this

Getting noticed

I often get this when enrolling new devices - I end up just leaving them for a while and it usually goes through. 


But If it's still not working I make sure I have gone to the play store for work Logged in with the same account that's linked to meraki SM (under Organisation > MDM > Android Enterprise) In the play store I check that the app is approved choosing 'Keep App Approved' under approval settings. 


You can then go into the meraki SM dashboard and 'reinstall missing' apps under the device.


This didn't work in my case:


I (re)approved the app on Friday, with the "keep app approved"-setting checked, but it still doesn't get installed.

I have an open case in regards to this issue. You will notice that the device owner is missing off the affected devices and also any change/ tag you assign will remove the generated owner name that is causing this issue.



- also it happens on all our Samsung device and Asus Nexus 7's in AFW owner mode



New here

Anyone have any luck with this? We have the same issue. It seems once the device is set up any apps we add later don't get added even though they're listed as "approved." We have over 300 devices deployed at this point and resetting them is not an option.

Nope, its and ongoing issues with the Meraki & the Android platform. Contact Meraki support and continue to hassle them so they get this fixed.

We've been fighting with them on this since June (case opened June 6). I was hoping someone else had some luck. I'll keep hounding them and hopefully "the engineers" will get this fixed.

We've had an open ticket on this issue since 04/06/2018. To date, it still doesn't work... I've moved away from Android and now only issue/allow iOS devices.

Here to help

I had changed the device owner to an actual user (Bill Smith <>) when this started happening to me and started see this same message when uninstalling and re-installing a play app on Android devices.  I changed the owner back to the original "Android Enterprise User (123ab)" that appeared when I added the device to Meraki and the apps installed and the message "Your administrator has not given you access to this item" went away.  The behavior of Android Enterprise devices and Apple Device Enrollment Program devices has a mighty steep learning curve IMO.

New here

Any updates on this one? Meraki Support did something with your case? It's 2019 and I have the same issue as the one you described... On some Android devices new apps install without any problems, and only on 2 devices every new app I want to deploy is pending. Of course every application is approved on Play Store and SM.


What's interesting, Xiaomi devices are working fine, and those 2 devices having issues are Huawei and ASUS. 



Ran into the same issue setting up a demo for a client.

I solved this by synchronising the Android Enterprise Apps, then I could install it on the phones.


When I tried to aprove the apps when I installed them, I got a error saying that Aproval failed.


It seems that it's the Aproval for the app is missing.

You can see the last sync status under System Manager / Overview, and sync from here.

If you go under Systems Manager / Apps, and add the column "Android Enterprise Aproved" then you can see your aproval state. 

My Apps was not aproved, you can sync from the Overview or from the Apps page under accounts. After a sync, I could aprove the Apps, and they installed on the phones.


Hope this helps

I'm not sure if your reply helps.

People in this thread have already approved their apps. (Also we have approved them).
But some people (including me) are still unable to install the apps on SOME of the phones.

I get an error "Your administrator has not given you access to this item."
But only if I use a whitelist in Android System Apps".
With a blacklist it's working.

And YES, I correctly whitelisted these apps. On most devices it's working. But on some (Samsung and Huawei) not.

I already started several cases for that. I also sent some ADB logs. But still the same.
What to do?

Ongoing case (04149194) on this Android app approval issue.

One factor that is certainly involved is a race condition between approval on Google Play Work website and approval in the SM Dashboard. It seems that unapproving on the Play Work web page then approving (only) on the SM Dashboard helps resolve the problem, at least in the short term.

I'll update this reply if I learn more - hope this helps someone.

New here

A solution that worked for me was to go into the Android phone, bring up the tile view of apps and close the GooglePlay app.  Go into settings/apps and force quit the GooglePlay app, then clear data.  Then go back into the Meraki app and click to install the app again.  It will load the app in GooglePlay but this time it will show as being installable.  At least it did for me.  Obviously, this is not a good solution for those that have mass deployments.  

A model citizen

Meraki and Android are currently causing only headaches. I hope the team is aware of it and isn't responding to this thread because they are hardly working on implementing Android Zero Touch, full Android Enterprise and full Samsung KNOX support.

Otherwise it's really hard to sell the Systems Manager to customers with only or a great amount of Android devices even as a MSP.


There is also potential on the Apple part to improve, but for Apple you can import a custom mobileconfig if something is missing.

Here to help



This is still an issue!


I'm rolling out 250 samsung A50's and struggling to get the apps on the devices. Exactly the same issues as described by others in this thread.

We did see, that when you leave the devices on overnight, that the apps were installed. I'm trying with another 60 devices to keep them on overnight and see what happens. For mass roll-out, this is a real pain.

Updated my case with support, including this link, hoping that it will be solved soon. Next time, i'll advise iOS again, or not to use Meraki MDM for the job.




There seems to be some sort of limit on the play store, so there is a limit on the amount of devices you can roll out per day. I don't now the exact numbers. If you leave your device on for a longer period of time, the apps will eventually be pushed to the device.

A model citizen

Do you use one user account for all devices or a bigger number of devices for one user account?

We are using 1 Google account for all the phones. Is there any way to have more than 1 account in Meraki MDM?

We also had feedback from Google saying that there is NO limit whatsoever for downloading apps or registration of phones via MDM's. Might there be a limit on the Meraki MDM then? I don't know, but there is still no clear answer.

BTW: The roll-out of the Android phones is gradually progressing. In case I know what limitations we have while staging the phones, I can plan on that. We can now roll-out around 40-50 phones per 24 hours. Some phones start rolling out immediately, others need to wait a few hours. I have no problems with that, as long as we know the limitations. And Cisco seems to be in the dark here, so they have no clear answers on what to do.
A model citizen

Just to clarify, are you using one Meraki user for all these phones or every phone has it's own Meraki user?


Have you enrolled to Android Enterprise in Meraki?

Get notified when there are additional replies to this discussion.
Welcome to the Meraki Community!
To start contributing, simply sign in with your Cisco account. If you don't yet have a Cisco account, you can sign up.