Update Meraki system manager app from 5.6.4 to 5.6.6

Simone-IT
New here

Update Meraki system manager app from 5.6.4 to 5.6.6

Hi , i ve got a notification to update Meraki system manager app from 5.6.4 to 5.6.6 for Android but devices are not allowed to update it and the notification keep poppin up.

 

there is a way to force update from the device manager as administrator?

 

thanks

9 REPLIES 9
reimpsel
Conversationalist

I am leaving a dot, since i have exactly the same question. 🙂 In device i am not allowed to update due restrictions and in managment portal under the device settings any other application has "update" button except Meraki application. 🙂

 

Best
Reimo

I just something simular, on a device i just installed with the system manager app 5.6.6 it started giving messages. 

 

Meraki SM upgrade 

New backpack item received on June 15, ... Download

 

there is a new version of the Meraki Systems Manager app available. please update.

Current version 5.6.6

new version 5.6.7    update

 

When I hit update it starts:  staging app   

and then a message Action not allowed ????

 

What's going on? why doesn't it update.

Thijs van Yperen
reimpsel
Conversationalist

Hey

Have you tried turning on automatic application update on Meraki Dashboard. 

 

reimpsel_0-1623841030464.png

After this i have no problem with applicatipon update. 

dade80vr
Getting noticed

Same here. From 5.7.8 to 5.7.9.

Keep app up to date is checked.

 

??

DLA2022
Conversationalist

Hi.

 

We had the same issue on all Android Phones (Android Version 9, 10, 11 & 12), turns out, you have to allow MERAKI SM app to install Unknown Apps in order to update the MERAKI SM.

 

1. Go to the Phone Settings

2. Go into Apps

3. Press the three dots in upper right corner

4. Select Special Access

5. Select Install Unknown Apps

6. Allow MERAKI SM to install unknown apps.

7. Exit to start screen

 

Go into the MERAKI SM app and update the Configuration Page and you should now be prompted to install MERAKI SM update.

 

Good luck 🙂

 

atedeschi
Conversationalist

When I go to do this, it is greyed out and says Disabled by admin. Did you have to change app permissions or anything?

Create a new profile and add Android Restrictions. Uncheck Prevent installation of apps from unknown sources and push it to your android phone and you should be able to install unknown apps.

It works, many thanks

van604
Getting noticed

thanks, this is great info in helping sort out the update issue, worked for me

Get notified when there are additional replies to this discussion.
Welcome to the Meraki Community!
To start contributing, simply sign in with your Cisco account. If you don't yet have a Cisco account, you can sign up.
Labels