Phone by Google app stuck on "set as default" screen

Here to help

Phone by Google app stuck on "set as default" screen

We have an oddball Samsung Galaxy S21 phone we are trying to manage.  All of our other devices are Apple but for some reason we have this one phone they bought.  This is the first android device I've tried using the MDM with.  Everything seems to be working except the Phone app.  I've whitelisted the system apps, added this app to my apps list, and installed it on the Samsung.  However when I open the app I'm stuck on the screen that has the "set as default" button.  Hitting the button does nothing.  We can call the phone and make phone calls via the contacts app but that's it.  I've gone into settings and made this the default app for phone, I've also gave it permission to make system changes but still, we can't get past that screen.  I feel like it's some sort of permission issue I'm over looking.


Any ideas?


Edit:  Apparently there was some sort of cache reset or something along those lines that one of my coworker did and that fixed it.

Get notified when there are additional replies to this discussion.
Welcome to the Meraki Community!
To start contributing, simply sign in with your Cisco account. If you don't yet have a Cisco account, you can sign up.