MDM Windows App install using MSI does not work!

Comes here often

MDM Windows App install using MSI does not work!

Hello! Any tips on how to deploy a windows app using MSI? The MSI needs elevated privileges/admin but I need to be able to install the software silently whether or not a user is logged in. 


I tried a couple of msiexec commands, see below. MSI is uploaded in Meraki cloud storage. 


msiexec /norestart /quiet /package "<full path to msi>"

msiexec /norestart /quiet /package "<full path to msi>" NM_ADDRESS_VALUE= REBOOT=ReallySuppress

10 Replies 10
Comes here often

Meraki MDM dashboard's  Activity log does say "success" but the software is not installed. 

Kind of a big deal
Kind of a big deal

You shouldn't need to be specifying the msiexec command.  Check out this article.

Thanks for pointing me to that link. Still did not work when I removed msiexec. Also, I completely removed the arguments still won't install. How do I tell MDM to install using the local admin user??

I *think* it installs it using the SYSTEM account - so no issue with rights there.


I think what I would do is get it working manually with the msiexec command yourself from the command prompt.  When you get the right set of options and can install it manually you should be able ot come back to the MDM and then set it up from there.


Some things that have caught be before - installs getting blocked because of a pending reboot from another update.

That's what I did, I manually run msi. If I manually run using local user it's asking for admin. If I manually run using admin, it works fine. And yes restarted the computer several times. 

What does the event viewer say?

No errors at all. No information/warning related to the install.

Head in the Cloud

@iamHueMan wrote:

MSI is uploaded in Meraki cloud storage. 



What do you mean by this? We deploy the Meraki SM via group policy with the MSI without any issue. What tool are you using to deploy it?

BHC Resorts IT Department

@BHC_RESORTS I think what they want to do is deploy another app using the Systems Manager agent on Windows.

@PhilipDAth Aha! That makes more sense.


@iamHueMan Well, in that case, lots of data was lost in the S3 loss a while back - any chance the MSI you have predates that? Some of the files we had "looked" like they were OK, but weren't when we tried to access them.

BHC Resorts IT Department
Get notified when there are additional replies to this discussion.
Welcome to the Meraki Community!
To start contributing, simply sign in with your Cisco account. If you don't yet have a Cisco account, you can sign up.