Kiosk Mode No on screen keyboard after device restart. Android 8.1.0

Wehttam
Conversationalist

Kiosk Mode No on screen keyboard after device restart. Android 8.1.0

Hi All,

 

We've just started noticing an issue with android devices that run our business app in kiosk mode. After the device restarts the on-screen keyboard does not appear. If you exit kiosk mode and reenter it the keyboard works fine until the device restarts again.  I've tried using a few different keyboard apps as the default as they all have the same behaviour.

 

Any help resolving this matter would be appreciated!

 

 

 

 

8 REPLIES 8
Alex1978
Conversationalist

Hi,

We too have noticed this behaviour over the past few days, it started out affecting one or two devices and has slowly spread to all. We too are using Android 8.1.0 with business app in kiosk mode but this is happening without a restart of the device. Also, the devices have scanners embedded and these too have ceased functioning.

Can I ask, how did you exit kiosk mode without having the on-screen keyboard? We had no choice but to wipe the devices and build them again - not fun at all but this was the only option. I'm expecting the issue to re-appear however, as the only conclusion we can come to is that a background Android or Meraki update has occurred?
Regards,

A.

Wehttam
Conversationalist

Hi Alex,

 

Our devices have a physical numpad that allows us to enter the code to exit kiosk mode.

Alex1978
Conversationalist

Thanks for your response, that makes sense - glad you were able to get out of it with relative ease!

Wehttam
Conversationalist

Any chance for a word from Meraki about this?

Alex1978
Conversationalist

I logged this directly with Meraki and their response was to follow the instructions on this page:

https://documentation.meraki.com/SM/Apps_and_Software/Controlling_Android_System_Apps

 

Which says:
"You may be required to add your device's keyboard app identifier to this system apps profile. For example, com.google.android.inputmethod.latin, for Google GBoard keyboard."

There was no device keyboard identifier that I could find so I used the GBoard one, however when I did this it then defaulted to applying Google voice typing as the input method, so instead of presenting the keyboard it prompts the user to speak into the device. Looking at the settings within the OS the option to turn this off is disabled! 

 

I'm about to respond to the Meraki ticket so will let you know if anything more useful comes back from it.

Wehttam
Conversationalist

HI Alex,

 

Thanks for updating this thread. Much appreciated!

Alex1978
Conversationalist

No problem!
I've got further with this now - as described above I had to add the keyboard app identifier to the system apps profile but it still wasn't working so I then added the specific GBoard app tag to the list of tags against each device and then it downloaded and installed GBoard.

 

Then I went into the settings on each device, into languages, keyboards, virtual keyboards, manage keyboards and could then add the GBoard keyboard. Once that had been added I could then enable the GBoard keyboard which finally allowed me to disable Google voice typing.

 

Now I finally have an onscreen keyboard available again. I have updated the ticket with Meraki to ask why the Android Keyboard has suddenly been removed but had no response as of yet.

 

The GBoard settings may need refining to suit your environment/needs - for example I removed the emoji keys, but at least it gets a working keyboard up and running again.

Alex.

 

random_helpdesk
Here to help

I can confirm that this problem is still happening on Android 8.1 with Meraki SM 5.8.8 installed in kiosk mode.

 

The on-screen keyboard only works until the device reboots, at which point it stops coming up. It doesn't even come up to let me enter the code to exit kiosk mode, so I have to untag the device in the web interface to get out of kiosk mode, then retag it and hope the tablet doesn't get restarted again.

 

It looks like this has been ongoing since 2019, which is frustrating. I just want to lock these tablets down to just the web browser.

Get notified when there are additional replies to this discussion.
Welcome to the Meraki Community!
To start contributing, simply sign in with your Cisco account. If you don't yet have a Cisco account, you can sign up.
Labels