Cannot add users in Apple Volume Purchase Program

Here to help

Cannot add users in Apple Volume Purchase Program



Is anyone else having problems adding / inviting new users in Apple Volume Purchase Program in Meraki Dashboard ?


This is not something we do very often as most of our staff were invited a long time ago, so I am usually just assigning apps to already invited users, however with recent new staff and a need to invite new users I have found this is now not working, although I have no idea how long it has been like this.


The symptom is that if I manually add a new user I get the usual "users will be registered shortly - all users registered", but no user is added, and no invite is sent. I can try adding the same user multiple times, each time it says it has succeeded, rather than saying that the user already exists. It even says in the recent activity tab that the user has been added, but it has not!


If I try a CSV import I get a different message, something like -  "Found 1 rows, 0 valid users" where it lists the number of users but says 0 of them are valid.


I've been in touch with Meraki support (an hour on the phone and an open case) and so far they've not been able to help and have all but said "everything looks fine from our end, we can't see any problem". When I asked them to try adding the users for me as a test I was told that they're "not allowed to make changes on a customers dashboard" which seems like a fob off to me.


This is very frustrating because we have just recently migrated our legacy VPP account into our Apple School Manager portal - which has transferred all unused licenses to the new VPP pool. This means I'm not even able to assign licenses to existing users because I need to re-invite all the users to the new VPP pool and can't invite anyone at the moment.


Anyone else having problems like this ?

13 Replies 13
Here to help

I am having the same problem . The last day I got one to work was March 5th. Under the recent Activity tab in VPP, it used to show

Activity details:

Registered new users (1):
  • (invitation sent)


And now just showing:

Registered new users (1):




I've been on the phone to Apple Education Support for an hour this morning, the guy was very helpful and went out of his way but the end conclusion is that the problem is not on Apple's side and that it must be a problem with Meraki or the Meraki Dashboard.


So back to Meraki I go again....


Did you get anywhere with this or is anyone else having issues with enrolling ipads into VPP? It would be very nice to be able to do this again as all my users are now working from home.



Meraki support have now acknowledged a "known issue" regarding not being able to invite VPP users however it is still not fixed and no ETA. Like you all our staff are now working from home for the forseeable future so this is a major problem for us.


I am continuing to chase Meraki but do not feel they are taking this seriously.

Meraki Alumni (Retired)
Meraki Alumni (Retired)

Please send me a direct message with the case number. Thanks.


Noah Salzman

Product Manager for Meraki SM

Hi Noah,


DM sent.


I too have this problem.

Managed to get 1 added but just won't work with the others.


Strangely I was able to add one user as well but only the one... every attempt since has failed including email addresses that have never been invited before.

Yep, I have 3 VPP accounts setup and I can add them into another VPP, but not the one that i want to.

Like you I've tried email addresses which have previously been registered and also using very randomly created ones that have never been used.


And still nothing.

Ill keep trying until i hear of a fix.





I was able to add 4 users without any errors this morning.


For me this is now resolved (for the time being)

I have added the users i needed to.

Thanks for the update. I just tried as well and I was able to add 3 successfully.
Meraki Alumni (Retired)
Meraki Alumni (Retired)

Thanks for the reports on success guys/gals. A bug fix went in on Friday for this.

Thanks - I tested this yesterday and it has worked for me on both VPP accounts as well.


Normally this would be a minor problem but in these days of needing to provision apps to staff working remotely at home it became a critical problem for us, so it's a relief to see it fixed.

Get notified when there are additional replies to this discussion.
Welcome to the Meraki Community!
To start contributing, simply sign in with your Cisco account. If you don't yet have a Cisco account, you can sign up.