Dell Laptops and VPN access.


Dell Laptops and VPN access.



We have been dealing with a very frustrating VPN issue that was only occurring with our newer Dell Laptops, below is the fix I found and wanted to share with the community at large.

Newer Dell laptops have a piece of software called "SmartByte" I found this piece of software was blocking our access to our VPN. Once I disabled this software I was able to successfully log in to the VPN. To fix the issue launch the "SmartByte" software from the Start menu. There is an on off toggle, turn off "SmartByte" and you are able to connect. You are able to uninstall the software and it does no harm to the system.

I am attaching a screen shot of the SmartByte screen as well.

This software is installed by default on all Dell laptop systems since about June of 2017.  I have not tested this with any desktop models.


6 Replies 6
Kind of a big deal
Kind of a big deal

Why of why do they put software like that on machines.

@PhilipDAth because someone at Dell is friends with someone at the company that develops that software. Just like everything in this world its about knowing people in the right places.

Getting noticed

I spend eaily 20+ hours online and offline with Meraki support regarding this issue with no resolution. VPN just dont connect with those new Dell Laptop unless i format it and reinstall a clean OS. SmartByte !!  Its you all along !! 

New here

On newer new Dell PC's (XPS 13 here) it seems SmartByte has been replaced with "Killer Control Center." Toggling off the "Advanced Stream Detect" switch under Settings tab in Killer Control Center fixes the 809 error when connecting to the VPN.

New here

Just an FYI, I thought this software was pointless so I tried to disable the service from taking away my precious RAM in the background. Needless to say, my internet did not work with or without VPN afterwards, so sadly this cannot be disabled further than the switch in the software.

New here

A friend bought a new Dell Inspiron 15, everything worked fine, but streaming through the VPN wouldn't stream, it just buffered or the program would play for about 10 seconds, then buffer. I offered to help, and after trying almost everything, I came across this web site, and read about Smartbytes and Dell laptops. While I was checking via the Dell Update program, an update for Smartbytes was there. I looked for it via Revouninstaller, found it and uninstalled it. The VPN works great and streaming is working great too. Thanks for the info re Smartbytes.

Get notified when there are additional replies to this discussion.
Welcome to the Meraki Community!
To start contributing, simply sign in with your Cisco account. If you don't yet have a Cisco account, you can sign up.