cancel
Showing results for 
Search instead for 
Did you mean: 

SM Update (2nd May 2019) - Missing Keyboard [Workaround]

Head in the Cloud

SM Update (2nd May 2019) - Missing Keyboard [Workaround]

RE: Systems Manager 5.1.5 | Release Date: 2nd May 2019

 

Android version? Android 7.0

Keyboard choice? Vendor Default - Gboard

Profile Black/White List? Whitelist

 

(The bit that is not clear, is that by enabling the whitelist profile even the default keyboard is blocked until it is added. For Gboard, the app package name is 'com.google.android.inputmethod.latin' which needs to be copied in to one of the whitelist fields)

 

Problem

Today, I setup a new device and found myself without a keyboard. This is a problem I have seen before so I thought I would share.

 

Pre-steps

The first thing to do is make sure you the Gboard app is your device keyboard in-use, if you unsure remove all device profiles on the device and then go in to Settings -> apps to see which yours is.

 

If you are using whitelist app permissions, make sure this is listed and the profile is on the device.

 

(The alternative is to install a third party App keyboard via System Manager -> Apps)

 

Workaround Steps

1. Open 'Language * input'
2. Select 'Virtual Keyboard'; make sure your keyboard is listed here

3. Open Default keyboard and select Gboard

 

This will result in the following and you should have your keyboard back!

 

AndroidKeyboard.PNG

 

I hope this helps!

Peter James

1 REPLY 1
Meraki Employee

Re: SM Update (2nd May 2019) - Missing Keyboard [Workaround]

That's brilliant, Peter. Thank you for providing this valuable information back to the Meraki Community!
Welcome to the Meraki Community!
To start contributing, simply sign in with your Cisco account. If you don't yet have a Cisco account, you can sign up.
Labels