Unable to get result when using the Postman collection Meraki Dashboard API - v1.1.0

SOLVED
VictorTJ
Here to help

Unable to get result when using the Postman collection Meraki Dashboard API - v1.1.0

When I run the get list of organization or any get calls I get 

{
    "errors": [
        "Invalid API key"
    ]
}
 
However I can use the same API key on previous Meraki Dashboard API
1 ACCEPTED SOLUTION
VictorTJ
Here to help

I was able to resolve this. The issue was the authentication was incorrectly set.

View solution in original post

8 REPLIES 8
VictorTJ
Here to help

I was able to resolve this. The issue was the authentication was incorrectly set.

What exactly was wrong with the authentication? I am having the same issue but can't find anything in the documentation about authentication other than setting the API key and bearer, and I am not using bearer.

Cole
Getting noticed

Can you elaborate on what was wrong with the authentication and where you fixed it?

Going from v0 to v1 of the Meraki API, I solved this by changing the name of the "X-Cisco-Meraki-API-Key" variable to "apiKey".

 

Clicking on the collection name, you can see that "X-Cisco-Meraki-API-Key" is now set using the "apiKey" variable.

+1

Jwiley78
Building a reputation

I keep getting same error with no luck yet of fixing it.  Any insight?

Jwiley78
Building a reputation

So I think I figured it out.  Once you edit your environment and save it you have to close the tab.  Once I closed the tab mine started working better.

Correct, make sure you always save your changes. I've learned that the hard way. 

Get notified when there are additional replies to this discussion.
Welcome to the Meraki Community!
To start contributing, simply sign in with your Cisco account. If you don't yet have a Cisco account, you can sign up.