SSL errors again

A model citizen

SSL errors again


I'm having SSL issues again.

On the computer I'm building my API app, everything works pretty much all the time no matter what I did with SSL verification.

I then use "auto-py-to-exe" to convert it to exe and move it to a fresh test laptop (doesn't have python natively installed), it fails SSL verification, unable to get local issuer certificate ssl.c:992.

I have tried using certifi,



tried downloading the server cert and pointing directly to it ..
I queried the server directly to check the cert was correct.

DigiCert Global G2 TLS RSA SHA256 2020 CA1.crt

(both of these options work on the build pc, not the test pc. The build pc also works if I don't specify any verification at all and don't import certifi)

On the test laptop I tried installing the cert just in case, but it made no difference. 

I checked both machines system variables in case there was any relevant difference - nope.
I made sure everything is up to date - auti-py-to-exe, urllib3, requests, python, certifi.
I tried rolling back to a previous version of auto-py.

If I disable the SSL verification, it works on the test laptop fine so I know the general code is ok, iv searched all over the internet and cant find an answer 😞

any ideas?

2 Replies 2
Kind of a big deal
Kind of a big deal

I suggest you open a support case.

I am not a Cisco Meraki employee. My suggestions are based on documentation of Meraki best practices and day-to-day experience.

Please, if this post was useful, leave your kudos and mark it as solved.

cheers, I looked deeper into it and it seems like the server isn't sending the full cert chain. Although I manually downloaded all the certs and bundled them together which should work but still nothing 😞

will see what support say 😄

Get notified when there are additional replies to this discussion.