Has getNetworkWirelessDevicesConnectionStats stopped working?

sungod
Getting noticed

Has getNetworkWirelessDevicesConnectionStats stopped working?

Hi,

 

with APIv1 and current release of the Meraki Python library.

 

I have a script that runs daily to gather connection stats for the previous day, I just noticed that since 6-7th January it has been returning empty connection stats.

 

It's the same on both Mac OS and Centos hosts, so it shouldn't be OS-related. There were no changes to the script. There were a couple of Python package changes (idna and Pillow) but not on/around that date, even so I tried backing out anything this year just in case, makes no difference.

 

It's affecting all organizations I access.

 

If I run a query 'manually' via the developer hub page, I do get stats back ok.

 

The call doesn't fail, it simply returns empty connectionStats for each device, for instance...

 

 

 

[{'serial': 'Q3AJ-...', 'connectionStats': None}, {'serial': 'Q3AJ-A...', 'connectionStats': None}, {'serial': 'Q3AJ-H...', 'connectionStats': None}]

 

 

 

Other API calls on the same orgs/devices all working as usual.

 

This is the usage...

 

 

 

connectstats = await aiomeraki.wireless.getNetworkWirelessDevicesConnectionStats(net['id'], t0=starttime, t1=endtime, ssid=netssid['number'])

 

 

 

I tried replacing variables with hardcoded parameters identical to what I use on the developer hub, still no data. Stripping down to bare minimum with just the network ID and a timespan is the same, no stats.

 

The call is 'succeeding' as it returns the device serial numbers, it simply isn't returning any connection stats.

 

I'm baffled.

 

Any ideas?

 

Thanks 

 

6 REPLIES 6
PhilipDAth
Kind of a big deal

Re: Has getNetworkWirelessConnectionStats stopped working?

Maybe trying updating the Meraki python library.  Something like:

pip3 install -U meraki

 

Otherwise you are going to need to open a support case.

sungod
Getting noticed

Re: Has getNetworkWirelessConnectionStats stopped working?

Both hosts were already up to date, but I tried forcing the package update just in case, no change though.

 

Wrote a new and simple script to query a single network, it returns null stats.

 

I also found running a query via the developer site on a single AP that Dashboard shows plenty of connection activity in the last day also returns a null result.

 

https://developer.cisco.com/meraki/api-v1/#!get-device-wireless-connection-stats

 

Now I have a support case open.

sungod
Getting noticed

Re: Has getNetworkWirelessDevicesConnectionStats stopped working?

Update

 

Case open and with engineering team.

 

Out of interest, does this call work for anyone? I've tried on three different orgs with the same results.

 

To test...

 

Login to Dashboard for an organization, then try this url, substituting the appropriate network ID:

 

https://api.meraki.com/api/v1/networks/PUT_NETWORK_ID_HERE/wireless/devices/connectionStats?timespan...

 

In the response, I get...

 

[{"serial":"xxxx-xxxx-xxxx","connectionStats":null},{"serial":"xxxx-xxxx-xxxx","connectionStats":null},{"serial":"xxxx-xxxx-xxxx","connectionStats":null},{"serial":"xxxx-xxxx-xxxx","connectionStats":null},{"serial":"xxxx-xxxx-xxxx","connectionStats":null}]

 

The V0 endpoint is still working, same network as above...

 

https://api.meraki.com/api/v0/networks/PUT_NETWORK_ID_HERE/devices/connectionStats?timespan=86400

 

[{"serial":"xxxx-xxxx-xxxx","connectionStats":{"assoc":11,"auth":16,"dhcp":0,"dns":0,"success":179}},{"serial":"xxxx-xxxx-xxxx","connectionStats":{"assoc":0,"auth":18,"dhcp":0,"dns":1,"success":254}},{"serial":"xxxx-xxxx-xxxx","connectionStats":{"assoc":23,"auth":25,"dhcp":2,"dns":1,"success":133}},{"serial":"xxxx-xxxx-xxxx","connectionStats":{"assoc":9,"auth":13,"dhcp":0,"dns":0,"success":157}},{"serial":"xxxx-xxxx-xxxx","connectionStats":{"assoc":10,"auth":6,"dhcp":1,"dns":1,"success":117}}]

 

 

krazeeEyez
Here to help

Re: Has getNetworkWirelessDevicesConnectionStats stopped working?

Yes there is def an issue, glad to find someone else complaining of same. Thought maybe something changed with the Python library causing the issue, but also confirmed in Postman - this call is always returing Null for every AP serial. Its doing this for both /networks/{networkId}/wireless/devices/connectionStats and  /networks/{networkId}/wireless/devices/latencyStats

 

Was about to open case as well. This definitely worked at some point

sungod
Getting noticed

Re: Has getNetworkWirelessDevicesConnectionStats stopped working?

Thanks for confirming it's not just our organizations affected.

 

I suggest open a case too.

 

With more people affected it may increase efforts to resolve!

 

 

 

 

sungod
Getting noticed

Re: Has getNetworkWirelessDevicesConnectionStats stopped working?

Can any of the Meraki people on this site get an update on this?

 

It is now almost four months since this API call stopped working in V1 (the equivalent V0 call works).

 

There's been a case open since January but support give no updates.

 

 

Welcome to the Meraki Community!
To start contributing, simply sign in with your Cisco account. If you don't yet have a Cisco account, you can sign up.