Unable to log a case and "Support number not recognized" when calling telephone support

dgriffiths
New here

Unable to log a case and "Support number not recognized" when calling telephone support

We are not able to log a case on the portal, when submitting it just disappears. 

When we try to call the telephone support and it asks for our support number, it says not recognized. 

 

I don't know how to log a case with them at all!!

9 REPLIES 9
alemabrahao
Kind of a big deal
Kind of a big deal

You can open a support case by phone:

 

https://meraki.cisco.com/meraki-support/overview/

 

I am not a Cisco Meraki employee. My suggestions are based on documentation of Meraki best practices and day-to-day experience.

Please, if this post was useful, leave your kudos and mark it as solved.

I can't - when I call them, it prompts for the "support number". Which I type in and it responds with Support number not recognised.  

You can ask them to open the case for you. Anyway, did you try another browser?

I am not a Cisco Meraki employee. My suggestions are based on documentation of Meraki best practices and day-to-day experience.

Please, if this post was useful, leave your kudos and mark it as solved.

Phone support is available for customers experiencing high impact issues where quick resolution is a top priority.

When contacting Cisco Meraki Support via phone, please have your customer number and support passcode ready found in the help tab of the Meraki dashboard.

I am not a Cisco Meraki employee. My suggestions are based on documentation of Meraki best practices and day-to-day experience.

Please, if this post was useful, leave your kudos and mark it as solved.

As already stated, I am not able to use the phone support either! It does not accept my customer support number. 

Well, you only have those two options. Via dashboard and phone. Try to open It using another browser.

I am not a Cisco Meraki employee. My suggestions are based on documentation of Meraki best practices and day-to-day experience.

Please, if this post was useful, leave your kudos and mark it as solved.

Yes I am aware of this, and hence why failing those two options I am trying the forum. I have tried multiple browsers, multiple networks, multiple Internet connections, multiple user accounts, multiple devices. 

I tested it here and It worked as expected.

I am not a Cisco Meraki employee. My suggestions are based on documentation of Meraki best practices and day-to-day experience.

Please, if this post was useful, leave your kudos and mark it as solved.
GreenMan
Meraki Employee
Meraki Employee

Email support@meraki.com

Get notified when there are additional replies to this discussion.
Welcome to the Meraki Community!
To start contributing, simply sign in with your Cisco account. If you don't yet have a Cisco account, you can sign up.