Invalid network ID

New here

Invalid network ID

I am trying to add an apple phone to my Device list. This will be the 147th device added. Whilst trying to enrol I get an "Invalid Network ID" message on the device.  I have tried manually entering the ID, scanning the 2D barcode, using the web interface All 3 methods fail.  I was able to enrol a device 3 days ago on Oct 15 however I cannot now. Any suggestions would be appreciated.

Kind of a big deal
Kind of a big deal

That sounds like a dashboard plug.  I'd try waiting 24 hours and trying again.


Otherwise you'll need to open a support case.

New here

We've just hit this error this morning on a new iPad. We are using Legacy SM. We'll try back in a bit.

New here

Any resolution on this? I am having the same problem.

New here

I am getting a similar error message, but with a Mac. I am re-enrolling a MacBook Air under Big Sur that has just been wiped. The error message is "Invalid Network ID," and it asks me for a Username and Password. I have no idea what Username and Password it might be asking me for, as the machine has been completely wiped and has no accounts set up on it. I had previously removed the profile from Meraki, and then removed the Meraki assignment from Apple Business Manager (though I tried it first before doing that).


Any suggestions for why this message might be appearing, or what it is asking for? All the messages I see online about this issue refer to mobile devices -- this is with a Mac.

Here to help

I'm having a similar problem.  I had an iPad that was, at one time, in supervised mode in Meraki MDM.  I used the MDM to erase and reset the iPad to factory conditions, but accidentally left it enrolled in DEP.  I then began the initial walk-through setup and found the iPad to be applying remote management.  Then, thinking that I could just remove it from DEP and release it from Apple Device Enrollment, I did that, and now the iPad is stuck in limbo.  It still thinks it is going to be remotely managed, but can't pull down a profile because Meraki MDM and Apple have no control over it anymore.  Do I need to use Apple Configurator at this point or is it a brick?

I have the same exact situation. Did you find solution to this or is the iPad a brick?

I was able to recover the iPad with Apple configurator.  If I remember correctly I had to perform a restore and software update on the iPad in order to get it to recover.  

I have Also the Same problem. Did you need to have the Ipad in your posession when you performed the solution? Or can it be done remote? 


You need Mac that has Apple Configurator installed. So if you have remote control to that Mac you can do it remotely.

Get notified when there are additional replies to this discussion.
Welcome to the Meraki Community!
To start contributing, simply sign in with your Cisco account. If you don't yet have a Cisco account, you can sign up.