Dashboard View Update - How to roll back to old version?

New here

Dashboard View Update - How to roll back to old version?

I just clicked on the option to view the new dashboard view, but don't like it. I can't find out how to roll it back anywhere!


Here to help

THIS. I made a horrible mistake by switching to the new UI, and I need to switch back ASAP because this is unusable. Someone please help.

Adrian Eilers

I have to scroll up and down to view my networks. Its showing up as only 2 rows in height, when I have the entire page available. Poorly designed and not tested properly before roll-out in my opinion.

I really don't like that they took the network side bar away either.  Would prefer the whole list from the original Dashboard. 



You can find here:



Just toggle the two slider buttons off and refresh page.



New here

Just called Meraki Tech Support and they had to switch it back for me on their end. Now I'm back to the original version that looks normal.

They have some bugs to work out for sure before pushing this new version out.

I just opened a case, hopefully they can roll me back without having to call 😞 

I just got off the phone with Meraki tech support myself to have them do the same thing, and I sent out a PSA to all my org Meraki admins to NOT enable the new UI dashboard.

Adrian Eilers

Same here. The new UI is buggy and the spacing is enormous on Chrome and Firefox.


I had to clear my cache to fix a bug with certain UI elements being hidden behind the big green bar at the top.


On the client list, with certain column options enabled, I can now only see NINE clients at a time without scrolling.  


I can only see FIVE networks on the list on the left without scrolling.  


I really hate that companies keep 'simplifying' their UI by taking much of it away and hiding it behind multiple clicks.  

Kind of a big deal

@MeredithW  - you might want to engage the right internal teams on this one. 

feedback doesn’t look promising 

Darren O'Connor | uccert.co.uk

I'm not an employee of Cisco/Meraki. My posts are based on Meraki best practice and what has worked for me in the field.

I think she's busy with Cisco Live right now, but I appreciate your help trying to get some more eyeballs on this!




Go to Organization > Overview

In the URL delete everything after the last slash and replace with early_access


so "[...]/manage/organization/overview#t=network" turns in to "[...]/manage/organization/early_access"


Turn off both sliders for "Magnetic Design System" and "New Landing Page"


credit to /u/czj420 on Reddit


@kbailey  for the win!

I tried the new layout, and promptly found that I was unable to add any new administrators. The button clicks, but the pop up box is greyed out. Same in several browsers. 

Kind of a big deal

https://n70.meraki.com/o/QBUGUb/manage/organization/early_access this link enabled me to revert back. Now I get not everyone is on of the say shard but adding manage/organization/early_access onto the end of your dashboard URL might work 

Building a reputation

I could not activate the Magnetic Design System (New UI) in my Organization, on the contrary.
But, I was able to activate it with another Organization linked to the same account. (on MSP Portal)


The following URL was accessed. The Magnetic Design System toggle cannot be enabled.


URL: [...]/manage/organization/early_access


I am contacting support.

Meraki Employee

Everyone should now see the Early Access page under Organization. You need to be an org admin to see it/edit the toggles.


It should show in classic and new views. If you're still experiencing issues accessing the page or operating the toggles please do open a Support case.


classic viewclassic viewnew viewnew view

Head in the Cloud

Uh oh .. Now this one just keeps popping up. Again, and again and again for every Org. In my dashboard I visit.

"Try now" worked on the first Org. (With all the , downsides that you can read about here, but nevermind that), but now when I press "try now" on a new Org. Nothing happens, and that same "pop-up" comes up again ... omg .... 

Perhaps a clear cache will fix things ? Who knows.... 😕



Does this mean that the NDA is lifted on this ? 🙂



Kind of a big deal

I saw the pop-up for the new dashboard and already knew it was going to be a huge mistake to try it out, so I didn't bother. Glad to see I was right lol.  Dear Meraki, please stop coming up with solutions looking for a problem. Did anyone even ask for a new UI or is this just like idle hands are the devils workshop type of thing. We don't need a new UI. We need you to make minor tweaks to the one we already know and love, like uptime on devices etc. Please don't reinvent the wheel 😃

Nolan Herring | nolanwifi.com

On some orgs, I can't roll back at all, it just refuses to let us click the sliders.

Also, when we tried it out on one org, it magically forced itself on ALL of our orgs...


This is just a mess, some UI elements are hidden by other elements.


Meraki -- I think you need to take this out of production, and beta test internally before putting this out to the wild.

Get notified when there are additional replies to this discussion.
Welcome to the Meraki Community!
To start contributing, simply sign in with your Cisco account. If you don't yet have a Cisco account, you can sign up.