Problem with MG21

Here to help

Problem with MG21

Hello community!


I have a Meraki MG21 that doesn't want to connect with Cellular. I've tried inserting the SIM card into a phone; it doesn't ask for a PIN code but says 'Carrier lock.' Does anyone know what this means? A quick Google search led me to understand that it might be if the phone had a previous provider, to which it is locked. But this shouldn't matter for the MG21 device, right?


The last thing i did was to connect it to the switch and enable safe mode for further troubleshooting.


Best regards,


Kind of a big deal
Kind of a big deal

Have you tested with another SIM card? It doesn't seem to be an MG problem.

I am not a Cisco Meraki employee. My suggestions are based on documentation of Meraki best practices and day-to-day experience.

Please, if this post was useful, leave your kudos and mark it as solved.

Thanks for the suggestion!


It's a remote site and we didn't have access to another SIM card, but that will be the next step to try for continued troubleshooting. I was mostly interested in finding out if anyone had experienced a carrier lock before and if that could have been the issue with the SIM card

Get notified when there are additional replies to this discussion.
Welcome to the Meraki Community!
To start contributing, simply sign in with your Cisco account. If you don't yet have a Cisco account, you can sign up.