Chromecast with Google TV - Can't Cast


Chromecast with Google TV - Can't Cast

Hello all. I work at a K-12 School district and we just received several Chromecasts with Google TVs and I'm having trouble getting them to work. My windows laptop (Lenovo L13 Yoga) and Chromecast are both on the same wireless network and I can see the Chromecast show greyed out in my casting options but cannot actually click it to cast to it (screenshot at the bottom of what this looks like). We have at least 60 Chromecast Gen 3s that we've had no real issues with for the past year and a half so I'm not sure what the issue is. I've tried creating a new SSiD and using a separate VLAN but did not make any difference. I also factory reset the Chromecast, allowed it full access on my content filter and still does not work. Strangely enough, it worked for several casts one one occasion but went back to no longer working after restarting it. I've contacted Meraki support regarding this but figured I'd reach out on here as well in case anyone else has experience this issue. My network is WPA2 with a PSK in bridge mode with our own DHCP server. 


Here's a picture of how the Chromecast shows in my casting options. It also does not work for "specific video sites" like YouTube as the message says. 



Thank you.

1 Reply 1
Meraki Employee
Meraki Employee

Hi Kayles,


Please post this on the Meraki Wireless LAN Community Page found here:

This group is for Meraki Wireless WAN, focused on our MG and MX/Z-C Platforms.


Thank you!


Get notified when there are additional replies to this discussion.
Welcome to the Meraki Community!
To start contributing, simply sign in with your Cisco account. If you don't yet have a Cisco account, you can sign up.