Windows 10 wifi clients in Meraki MR42 (firmware 25.13) environment


Windows 10 wifi clients in Meraki MR42 (firmware 25.13) environment


we have MR42s installed with firmware 25.13 (and experienced this with firmware ver 25.11) where we have seen Windows laptops exhibit the following:

1) laptop is brought in from home and fails to connect to default programmed SSID (WPA2 key'ed).

2) laptop just loses an internet connection.

3) laptop has poor reception (clicking on the wifi icon in the system tray didn't see any networks, yellow '!' appears).

4) laptop shows no internet secured (clicking on the wifi icon in the system tray)


we have noted the following 

a) a windows security update did fixed a one-minute lag (mentioned in item #4 above) in auto-reconnecting to the default programmed.

b) just discovered that today.... a windows settings > networks & internet > status:  clicking on the network reset button seems to resolve item #1 above.


However, just to be thorough, has anyone seen any issues with MR42s (ver 25.13) using WPA2?  Any insights related to Windows 10 settings/fixes would also be most welcomed.


Thanks, -Tom

21 Replies 21
Kind of a big deal

I would lean towards this being potentially a laptop issue versus MR42. What specific wireless chip-set do your laptops have and what version driver are they on?

If it is on the Meraki side, I would look at the config first
Nolan Herring |

We haven't had any issues with clients connecting to MR42's using 25.13 across our entire customer base.


I'm with @NolanHerring, with this being a notebook chipset issue.  Are there some common brands or models with the issue?


My next thought is you might be having RF issues.  If you are using 2.4Ghz spectrum - see if you can turn this off and only use 5Ghz. 2.4Ghz has too many issues these days.

We have several Dell Latitude E5450 (AC-radio) and Dell Latitude 3330s (N-radio).


Dell and HP14 chromebooks are very stable (both AC radios).

If the Chromebooks have a solid connection, and in the same environment the Dell Latitudes do not - it has to be the Dell Latitudes.


Are their any WiFi driver updates available for them?

Is it possible that the MR42 may encounter trouble with the windows laptops if they are the last to associate after several chromebooks and a dozen or so Android/iPhones do so first?  I know the MR42 model are rated for 75 devices so I'm inclined to think it is still a device driver or hardware issue on the Windows laptops.

Did you find a solution to the issue?


I have the same situation, only the Windows computers have disconnections, weak WiFi signal, and show the yellow triangle with the exclamation point. Our Chromebooks and Macs work fine.


I have AP MR34 with firmware 25.13. Justin, Meraki Supervisor, mentioned that they are not aware of this issue. Did you have a case number I can provide as a reference to Meraki?

Have you found a solution for this issue? I have the same situation and it happens from time to time only for windows machines!

Just to expand on something that was asked by another in this conversation.


I went through this with the exact symptoms you describe on Windows only systems.  In my case it turned out to be the specific version of the wireless card driver (USB wireless in my case).  I had a slightly out of date driver installed but proved out that both the driver version just prior to the one installed and the latest driver that was recently released work correctly.  No Meraki or Windows settings were changed, only the driver version was changed.


Since either rolling back or upgrading the wireless driver on the PCs, I have not had a single connection issue and that was more that a month ago so I'm pretty confident in the solution as this computer lab is used heavily every day.


Hope this helps.



Thanks for your reply, May I ask to share the USB wireless model and driver that you've used for this test, will great help for me.

The USB adapter is sold by StarTech but is actually the following chip and driver:  Realtek RTL8811AU Wireless LAN 802.11ac USB 2.0 Network Adapter (Driver version: 1030.11.503.2016)


The driver was updated in 2016, 2017 and 2019 (as noted by the last four digits in the driver version).  In my case, the driver from 2016 and 2019 work correctly but version 2017 has the same connectivity problem as was described in this conversion by a couple people. 


Hope this helps.

Building a reputation

I am running MR42's with the 25.13 and hundreds of Win10 laptops and not heard of this happening. Initially I thought I had heard of Win10 having some wifi issues but that was when it was first shipped, nothing recent unless its Wifi card specific.


Good luck in your search, these types of issues can be trying.



What do you mean under "wifi card specific"? That could be a clue to what's happening. Thanks.

Building a reputation

I had some Windows 7 devices experiencing a similar issue and it turned out to be the specific card not playing nicely, not the system itself.  When we eventually migrated away from that model the problem went away.  We made some card configurations (under device manager) to lessen the issue until that time.


We're seeing this same issue with the new HP EliteBook x360 830 G6.  We've imported drivers with the HP MIK into SCCM.  We're seeing the yellow bang on WiFi in the system tray and the "No Internet, Secured" message for WiFi connections that are able to browse the web.  The WiFi adapter in these laptops is the Intel AX200NGW (WiFi 6).  We are currently deploying Windows 10 Professional 64-bit (1809).

Unfortunately, the only workaround that I found is to isolate all the windows PCs on a serrated SSID (as my network is mixture of Linux, Windows, Mac). Friend of mine is facing the same issue at co-working space where Meraki APs are used as well. I don't understand why Meraki negligent this problem.

Kind of a big deal
Kind of a big deal

We have had the same issue with some Windows 10 Dell devices and believe in our case that it is more related to our non-Meraki firewalls as a different SSID for public use that goes out through an MX is okay.  Have you tried that to see if it is the case?

That's strange, it means that you must use only Meraki. We've used MX and we've experienced the problems, then replaced them and the problem is still present.


That's strange, it means that you must use only Meraki. We've used MX and we've experienced the problems, then replaced them and the problem is still present.

Head in the Cloud

We solved several problems on our dell notebooks by doing a firmware update and driver update for the wifi network device.

In my cace even after a full drivers update the problem still persists(Lenovo T470,T480,T570,T580).

Building a reputation

Something I've found recently that seemed to help was changing my channel width to 20MHz instead of 40 or 80.  Talking about brand new Dell laptops that should work with any but seemed problematic until I did this.

Get notified when there are additional replies to this discussion.
Welcome to the Meraki Community!
To start contributing, simply sign in with your Cisco account. If you don't yet have a Cisco account, you can sign up.