MR42 no longer broadcast SSID

Here to help

MR42 no longer broadcast SSID

MR42 is no longer broadcast SSID.
we have 2 SSID, now 1 SSID is no broadcast anymore.

This is third time of this issue after new using Meraki since Feb2018.
I saw in the knowledge base about SSID availability  but can't fix it.


1 Accepted Solution

I haven't personally had any issues with that version - but lots of other people have.  I would upgrade to 25.11.



View solution in original post

22 Replies 22
Kind of a big deal
Kind of a big deal

Are you say it was broadcasting the SSID, you changed nothing, and it stopped working?


Is this happening across multiple client types (aka, PC, smartphone)?

yes, I did not change anything and also face the issue for all client .  laptop, IOS, Android

What firmware version are you using?

I checked  2 AP from 9 AP..  


Up to date
Current version: MR 25.9


I haven't personally had any issues with that version - but lots of other people have.  I would upgrade to 25.11.



Thank you for your advise, I set the schedule to update firmware by this evening.

I will tell the result once success update firmware.

Kind of a big deal

I've periodically had this issue.  Usually a reboot of the AP resolves it.  I'm hoping the Wireless Health analyzer helps identify these issues in the future without it having to be reported from a user first. 

If this was helpful click the Kudo button below
If my reply solved your issue, please mark it as a solution.

I did to update firmware and the problem was gone . Thank you so much.

I try to checked by myself on the knowledge base. but can't fixed even I set SSID availability is disable/ or set to enable . This is the 3rd time which I faced this issue.
since I purchased feb2018 1st and 2nd time of problem I fix it by reset to factory due to trial usage but now 2 SSID are production environment , please help to fix and tell me where is a root cause


I agree in upgrading to 25.11.  It addresses that issue specifically.  I have applied it to a customer late last week and so far no problems.


Bug fixes

  • AP spoofs not being detected. (MR52/72)
  • A corner case where AP broadcast on W52 channel when in site survey mode (MR84)
  • A corner case where AP would stop broadcasting SSID (MR30H/33/42/53/53/74/84)
  • A corner case causes AP to reboot (MR18)
  • A corner case causes AP to stop responding to clients (MR32)
  • A corner case causes APs lose connectivity to dashboard until reboot in certain cases (MR33/74)

We had the same issue with 25.14. I opened a case, they said this is a known problem and should be resolved with 26.6


Here to help

I know this is a big time thread revival...but as of today (12/3/2019) Cisco Meraki support has confirmed there is an active bug with ONLY MR42's running ONLY Software Version 25.14.  I was running into this the past few days and kept chasing my own tale rebooting AP's per location.  Turns out a reboot is a temp solution, but upgrading is the end solution.  

Thank you! I have been pulling my hair out thinking it was something I had done!  This is the exact issue that led me to this post.  When will the update be available?  We are a school in the midst of exams and have had to reboot the APs twice already.

Haha!  I know right?  You and me both!


So an approved update is already available, you’ll have to go in and start the schedule process and then choose whatever the option it is… I think it’s called something like approved use update. If I recall the version was 26.2.  This will be at Network > Configure > General


Support said to go to 26.6.  I did that overnight and it has been solid today.  Restarting the APs seemed to "fix" the issue before, but after 2 days, the problems continued.  So far, so good!  If anything changes, I'll let you know.

Yes, apologies.  26.6 is the correct approved update.  

For the last two months we have had multiple clients battling this issue and nowhere can i find any reported/documented info on the issue, except for this thread


Then over the holidays I saw that mr25.14 had been pulled from the available firmware list.

My question is where does everyone go to find out information like this?

is it documented any place other than opening a case to ask the question?

are you notified by meraki that it is being pulled?

is it posted any place what the recommended mr firmware should be that fixes the issue?


This cant be the only place we find out about these issues



Mark Earles

Honestly; I got to the point where the resolutions I found (ie: this one) were so old I didn't know if they were applicable any longer or if they would be relevant with my model 42's so yeah... I had to open a ticket and the rep told me straight up over the phone what the issue was.


I have worked with Cisco on a number of platforms over the years and 'bugs' don't always legitimize until well after they have a resolution for them.  It feels like company standard practice for them to not publish it until they absolutely have to.  TBH. 

Head in the Cloud

I have got a lot of MR42 and had the same issue. After upgrading to version 26.6 everything works fine.

How do you get to 26.6?  All my dashboard shows is the 25.14 and says up to date, but we are having the same issue here.

Head in the Cloud

Organization - Firmware upgrades, Choose all networks, choose you network you want to upgrade

Bildschirmfoto 2020-01-10 um 08.14.57.png


Bildschirmfoto 2020-01-10 um 08.11.20.png

Got it.  It was under the Stable release candidate option.  Looks a bit different to yours now..




Get notified when there are additional replies to this discussion.
Welcome to the Meraki Community!
To start contributing, simply sign in with your Cisco account. If you don't yet have a Cisco account, you can sign up.