MR access point

New here

MR access point



I am receiving a message on my access point containing the following.



"This device is using a DHCP IP address from VLAN 0 instead of using configured VLAN 1."

22 Replies 22
Getting noticed

set the native VLAN on the switch you are plugging it on to the VLAN you want to get the address to and under the DHCP settings on the AP remove the number in the VLAN box. I had same issue. If you dig around it is something about double tagging.

Hi Timbisel,


Thanks ! that took care of that issue, however I am now getting a :


DNS is misconfigured


for reference, I have the MR AP setup on my cisco switch as an access port on our wireless vlan 50

Are you using DHCP or a static IP?

this would be Static, you just reminded me we have our enterprise network setup for static. I will play around with that and see if I can get it going.


Thank you !



I had stuff act funny when I configured the static IP on the AP with different sub DNS then what the DHCP server normally had for that subnet.

Example I used basic Meraki DHCP with google DNS for guest network ( but when I put in static I used ( changed that to match and power cycled and it worked fine
Kind of a big deal

I agree with @TimBisel


That DNS is mostly for the device to just checkin to the cloud.  So public DNS like etc is fine. 

If this was helpful click the Kudo button below
If my reply solved your issue, please mark it as a solution.
Here to help

I am having this same problem. I have my MR33 connected to a MS120 port configured in trunk mode with native VLAN1. The AP is up and working, and clients can connect to it normally. How do I clear the error?

Which error specifically are you getting @rrehart01 ? 


There were several mentioned in this thread originally.

Nolan Herring |

"This device is using a DHCP IP address from VLAN 0 instead of using configured VLAN 1"


When I try to statically address the AP with the exact same address, I get "Bad IP assignment configuration", and it still shows "(via DHCP)" on the console


Config Example.jpg

Can you show me the port config on the switch, that the AP is plugged into. Port 7
Nolan Herring |

Yep (and yes, I'm aware its only a /28 - that's on purpose).


Swtich Config.jpg

Switchport 'looks' fine. Where are you seeing that error about VLAN 0?
Nolan Herring |

On the AP when it's configured to use DHCP (I have a reservation for that in my router)

Remove VLAN 1 from the AP static configuration. Hit save. Let me know what happens 😃
Nolan Herring |

Same result. "This device is using a DHCP IP address from VLAN 0 instead of using configured VLAN 1."


Although, now the LAN IP says " (statically assigned)" vs. " (via DHCP)"

If you have DHCP reservation for that access point, then you should choose the DHCP mode. Just leave the VLAN portion blank.

If you are configuring it with a static on the AP itself (and not using DHCP) then still leave the VLAN portion blank.

You might have to bounce the port for this to resolve.
Nolan Herring |

Bounced the port. Still the same. BUT! I think I see the problem after doing a packet capture. I think the problem's at the router. Since that's not a Meraki, I'll work with the site to bounce it. Thanks for the help

I doubt its the router. The error message is L2 related. Since you have the switch port configured as a trunk with native vlan 1 configured, the AP configuration should be set to no vlan tag configured, otherwise you'll end up with a double tag issue (error message).

So since you have the native vlan on the switch, you don't need to put a VLAN on the AP side.
Nolan Herring |



On second thought it might be something further down the line if the AP can't reach the cloud with that static IP. Make sure the VLAN 1 can get all the way out.

Nolan Herring |

After going through all possible troubleshooting, I gave up and factory reset the AP. Miracle of miracles - IT WORKED!  All green now.


Some mysteries will never be solved...

Leaving the VLAN field blank resolved my issue, thanks.

Also, your aware you have your subnet size set to /28 right?

16 IP addresses. Just making sure 😃
Nolan Herring |
Get notified when there are additional replies to this discussion.