Google OAuth sigon for Splash - Meraki Wireless

Just browsing

Google OAuth sigon for Splash - Meraki Wireless

Hi Guys,


I have an unusual behaviour I need help with. I have Google OAuth enabled in my test environment (trying out a coffee shop styled wifi), and using the domain of my company (our emails is by Google) as allowed domains.


Walled Garden to allow:





It works well for people using Mac in my company. However, for Windows laptop, iPhones and Andriod mobiles, I get a 400 error.

"The server cannot process the request because it is malformed. It should not be retried."



So only MacOs works for me.

Note, I have not enabled anything from the Google admin console, as I believed OAuth should work without the need for that.


I'd appreciate any help or pointers or for those that have faced this issue, how did you resolve this?

4 Replies 4
Getting noticed



Pls add below also to the walled garden and let us know.




Thanks man, that solved most of the issues. Android mobiles and Windows laptop now connect.


I still have an issue with iOS. I now get Access Blocked: Authorization Error

Error 403: disallowed_useragent




Kind of a big deal
Kind of a big deal

Check the documentation here.




I am not a Cisco Meraki employee. My suggestions are based on documentation of Meraki best practices and day-to-day experience.

Please, if this post was useful, leave your kudos and mark it as solved.
Meraki Employee
Meraki Employee

Get notified when there are additional replies to this discussion.
Welcome to the Meraki Community!
To start contributing, simply sign in with your Cisco account. If you don't yet have a Cisco account, you can sign up.