Configuring AP without DHCP

Here to help

Configuring AP without DHCP

Hello all, 


I'm on a trial with the MR52 APs and they worked great with DHCP but the building I'm wanting to use these in has everything statically assigned. I changed the IP settings in the dashboard and tried to connect the APs at that location but the lights kept doing the rainbow color change like it was looking for the controller. I tried the steps listed under this article to try and access the AP locally but didn't have much luck:


I don't have an AC adapter so the APs were being powered via PoE. Tried factory resetting the APs and unplugging one but didn't see the default SSID being broadcasted. Also tried connecting to meraki-<MAC ADDRESS> with no luck there either... Anything else I could try to access this AP locally so I can see what's going on?

1 Accepted Solution

I think I did. I ended up using DHCP at our main office to get the AP connected to the cloud, made my configuration changes on the AP itself and will try hooking it up at the other location later this afternoon. 

View solution in original post

16 Replies 16
Kind of a big deal

I have to ask: is there any possible way to put a DHCP server on a vlan there for these APs? Better practice is to use DHCP with reservations.


Is the AP accessible if you take it back to a location with DHCP?

Kind of a big deal

@Nash is he able to get into the local status page without configuring the AP? I forget. He might be able to set a static there.


No, it's at a detention center and the director requires all of our equipment to have static IPs. But when the APs are used on our network at our main office they work fine. I can't tell if it's taking the IP though when I change it to static as it's not reflected in the dashboard but it does stop communicating with the cloud so I'm assuming the IP is sticking but soon as I take it over to the other building I'm not seeing it in the cloud anymore. 

Kind of a big deal

Assigning IP Addresses

All gateway MR52s and MR53s (An AP with Ethernet connections to the LAN) must be assigned routable IP addresses. These IP addresses can be dynamically assigned via DHCP or statically assigned.

Dynamic Assignment

When using DHCP, the DHCP server should be configured to assign a static IP address for each MAC address belonging to a Meraki AP. Other features of the wireless network, such as 802.1X authentication, may rely on the property that the APs have static IP addresses.

Static Assignment

Static IPs are assigned using the local web server on each AP. The following procedure describes how to set the static IP:

  1. Using a client machine (e.g., a laptop), connect to the AP wirelessly (by associating to any SSID broadcast by the AP) or over a wired connection.


  1. If using a wired connection, connect the client machine to the AP either through a PoE switch or a PoE Injector. If using a PoE switch, plug an Ethernet cable into the AP’s Ethernet jack, and the other end into a PoE switch. Then connect the client machine over Ethernet cable to the PoE switch. If using a PoE Injector, connect the AP to the “PoE” port of the Injector, and the client machine to the “LAN” port.
  2. Using a web browser on the client machine, access the AP’s built-in web server by browsing to Alternatively, browse to
  3. Click on the “Uplink Configuration” tab. Log in. The default login is the serial number (e.g. Qxxx-xxxx-xxxx), with no password (e.g., Q2DD-551C-ZYW3).
  4. Configure the static IP address, net mask, gateway IP address and DNS servers that this AP will use on its wired connection.
  5. If necessary, reconnect the AP to the LAN.


I hadn't tried plugging into the same switch that the AP was plugged into...I'll give that a shot real quick. 

@kYutobi No luck doing that either. just displays "Page cannot be found".
Computer is plugged into the same switch.

Did you connect to the default SSID that it should be broadcasting (assuming it hasn't reached the cloud yet), that is how you should be able to access the
Nolan Herring |

Oh sorry, just saw you mentioned it isn't broadcasting anything. Is it just this one AP? If you did a full factory reset it should start broadcasting the default. That's odd.
Nolan Herring |

Honestly its probably easier to get them to the new site (the one that requires statics), and let them get online via DHCP. Then set the reservation on the DHCP server, which is basically the same as configuring them statically, just easier.

You should have a dedicated VLAN for the access points and only the access points to live on as well.
Nolan Herring |

I agree, it would be easier but they won't let me configure a DHCP server for that building.

Not sure if you solved your issue but I have been successful setting the APs to static IPs.  The best way to set the static is not to enter a VLAN, leave it blank, I generally use Google DNS servers which should allow the AP to reach the internet.


I think I did. I ended up using DHCP at our main office to get the AP connected to the cloud, made my configuration changes on the AP itself and will try hooking it up at the other location later this afternoon. 

What I tried worked. The static settings stuck and the AP was able to connect at the other location. Not sure why I couldn't access that default SSID even after factory reset though.
Thanks everyone!

@NolanHerring it's two APs. Factory reset them both and the default SSID isn't broadcasting.
Kind of a big deal

I see. One could have a dhcp server with reservations for each available IP, but arguing this is... difficult... when people are stuck on statics. Especially when they have confused static IPs with security measures.


Have you tried setting it with a static IP valid for the building w DHCP? To ensure that your process is correct? As @kYutobi notes, you’ll need to set it via local status.


Doing it in the working building ensures that your AP will be able to pull a config easily if you need to reset it again.

I said the same thing but was told people could easily bypass reserved IP addresses by just manually changing their IPs...

Yeah I changed the IP to one available for the building prior to testing it there. Made the change in the dashboard, AP was no longer communicating with the cloud as the IP isn't valid in my office, just at that building. Plugged it in and it just looped the rainbow LEDs. Tried to access the local status page there but wasn't able to access the AP.
Get notified when there are additional replies to this discussion.
Welcome to the Meraki Community!
To start contributing, simply sign in with your Cisco account. If you don't yet have a Cisco account, you can sign up.