Apple and Android devices forgetting/not auto-reconnecting to Meraki mac-based access control SSID

Comes here often

Apple and Android devices forgetting/not auto-reconnecting to Meraki mac-based access control SSID

Recently I have been having issues with a Meraki mac-based access control SSID. The issue occurs when an Apple or Android device will go to sleep, and when the device is woken back up, the SSID has disappeared from the device. You can re-enter the network settings on the device and it will connect again just fine, but once the device goes to sleep it will forget the network setting again. This is occurring on random devices, and really frustrating our Users. I hope someone here can help me out. 

9 Replies 9
Kind of a big deal
Kind of a big deal

Is disabling device sleep an option?

I am not a Cisco Meraki employee. My suggestions are based on documentation of Meraki best practices and day-to-day experience.

Please, if this post was useful, leave your kudos and mark it as solved.

So you can do this on Android devices, but not Apple devices(that I am aware of). So it may fix the Android devices, but not the Apple devices. So I don't know if this would fix the issue. 

Getting noticed



To prevent Mac from sleeping:


Open Terminal

Run sudo pmset -a sleep 0


Then also follow below tasks.





(To verify whether en0 or en1 active for wireless)


Under terminal,


cd /System/Library/PrivateFrameworks/Apple80211.framework/Versions/Current/Resources


sudo ./airport en1 prefs DisconnectOnLogout=NO



Also, under the terminal, make following changes


./airport en0 prefs


Disconnecto logout=NO







Building a reputation

Think it's about Mac adresses, not Mac devices 😄

Was reading again. Device going to sleep is the problem right.

Yeah, basically an Apple iPhone/iPad, or Android device will go to sleep. Then when it wakes up the network is no longer exists in the devices network settings.

you can re-add the network, check for it to auto re-connect, but the same thing happens next time the device goes to sleep. When wakes back up and the network is nowhere to be found on the device.

Building a reputation

Hmm. Is there some client privacy feature activated? In case the Mac address does not persist, I would try to change it. Or at least reconfigure the WiFi network on the device/s.

Comes here often

not that I am aware of, none of the clients have an MDM on them. The devices just forget the network all together when they wake back up. I've even tried resetting the network settings on the problem devices, and factory resetting them, but the issues still persists.

Other devices have no issues, it's just a random set of devices that do it.

Kind of a big deal
Kind of a big deal

Have you got the SSID set to be hidden?  If so, make it visible and the issue should go away.

Get notified when there are additional replies to this discussion.
Welcome to the Meraki Community!
To start contributing, simply sign in with your Cisco account. If you don't yet have a Cisco account, you can sign up.