VPP Apps not updating correctly

Here to help

VPP Apps not updating correctly

I have a few apps assigned through VPP and I noticed the update behavior has recently changed.   


The app is successfully setup in VPP.  Under Systems Manager/Apps, the app currently shows version v3.38.  The "keep app up to date" option is NOT checked, and the Purchase method is VPP device assignment.  The current version for the app in the Apple App Store is v4.2.  Until recently, deploying the app through Systems Manager would push the 3.38 version as this is the current version setup in VPP.  For example, if I setup a new iPad or factory reset an older one, v3.38 would be pushed to the iPad.  


Sometime recently this changed.  Pushing the app down from SM now deploys version 4.2, which is the version in App Store.  It seems to be bypassing the VPP setup completely.  I have tried this on several iPads and the results are the same. This is a problem as we need to control the deployment of the app independently from the App Store availability.


Any ideas why an update would be pushing the App Store version down and not the VPP version down as it did in the past?


Many thanks!


Kind of a big deal
Kind of a big deal

@SteveGB  from what I understand all App's are downloaded via the App store, the only difference is the way the licensing is applied. VPP is just a means to purchase licensing app do not actually download from VPP.



Have you made any changes to the devices like update to OS version? If so updating the OS may have allowed the device to run the latest version of the app you are using. 


Thanks, I understand VPP is used to license the app.  When using device management without an Apple ID deployed on the iPad, the app version is definitely controlled under Systems Manager/App settings and not through the App Store - at least is used to be. 

A model citizen

The only thing I can think why this happens, is where Apple or the Developer isn't "signing" the old version anymore.

Kind of a big deal

@SteveGB App deployment through Meraki is dependant on what is available through the App Store. Meraki does not keep a library of apps. 


I know this as I have watched the logging when troubleshooting app installs in the past. Meraki's MDM makes a call out through the app store when downloading apps. 


I know with iOS 12.1 Apple and Meraki finally fixed the issues that were keeping Apps from auto-updating as part of the check in process. 


The only way that I would know to control which version of app is on an iPad and not use what is available through the app store is to load it as an Enterprise app through Meraki.

Found this helpful? Give me some Kudos! (click on the little up-arrow below)

Hi @vassallon ,


Where is this "I know with iOS 12.1 Apple and Meraki finally fixed the issues that were keeping Apps from auto-updating as part of the check in process. " information? This is good news!


Thank you,
Peter James

@PeterJames I haven't seen any specific mention of it in any documentation. Just from experience, I have seen apps auto-updating on iPads since 12.1 was released, this was behavior that never worked previously even with apps set to auto-update.


For example here is an iPad running 12.1.4 which had the app update trigger.



Found this helpful? Give me some Kudos! (click on the little up-arrow below)
Head in the Cloud

HI @SteveGB ,


We have always used device-based VPP and whilst the App page itself requires to have the button 'Refresh Details' pressed to update, all installs will be the latest version available.


When an App install (an update is actually the same command) is triggered, all Meraki does is talk to the Apple API's which then pushes the App meta data to the device, and then the device works out which version it should download (or rejects the download if incompatible).


A more technical response can be found in the Apple MDM Protocol documentation [here].


There are three reasons I can think of that a prior version would install:
 - You had an iOS version that was incompatible with the latest app version

 - You switched from B2B to VPP or Custom upload to VPP

 - You have a caching server in play which had not updated, but the meta data had already reached the device


I hope that helps.


Thank you,
Peter James

Get notified when there are additional replies to this discussion.
Welcome to the Meraki Community!
To start contributing, simply sign in with your Cisco account. If you don't yet have a Cisco account, you can sign up.