Problems re-installing profile on iPad

Here to help

Problems re-installing profile on iPad

Hello Community,


I have a very remote user who has somehow removed the Meraki Management profile which had the use of Safari turned off.


Is there a way to re-install a profile on an iPad without the use of Safari? (And preferably not wiping the iPad as that would require them to enter stuff I would prefer them not to enter)


Thank you in advance,


New here

There is an option in Systems Manager to reinstall the profile.


edit: From the dashboard, I mean

Hello Stickells54,

I don't believe that is a workable solutionas the iPad has severed ties with Meraki.


Refreshing profiles, Reinstalling profiles and the like haven't given me back control of the device.  It still has "Management profile has been removed from device!" in a red box on top of the Dashboard.


Next suggestion?


Was this a DEP or manually enrolled device?

Find this helpful? Click the kudos button. Thanks!

The device is enrolled in DEP.


Was the MDM Profile (AKA "Meraki Management") made mandatory is pre-stage enrollment? Is the profile still on the device? If so, how did the user remove it? Meraki has a fail-safe in place if a DEP device severs connection it will allow the device to be enrolled without a total wipe. Usually, this can be done if you go to Seeing that they don't have Safari could they get Chrome and try? If not, you would need to find them a way to get your profile from Dashboard to re-enroll.


By the way, in a rare case, it is a Meraki/Apple issue when profiles stop communicating with the server. This looks like the profile has been tampered with by the user. I am not trying to accuse, but give you a heads up!

Find this helpful? Click the kudos button. Thanks!

Hello Jared,


I do not have access to the device, I can only view it on the management console. only works on Safari.


I think I am out of ideas and will have to get them to return it to base.  I don't know how it was removed, I know there are few rogue staff, one of which is a director.  

Thank you for trying to help.

@Bruce_Sayers Users can keep you on your toes. I started providing our WiFi via certificate and a network payload. If you don't want your device enrolled, enjoy the data bill. All of our iPads are DEP and the profile is marked mandatory and cannot be removed. But, even people are trying to get around DEP now, found this latest surprise when I was on eBay a few days ago:


I wish users could see what I can view in Dashboard, there is this large misconception that I can see text messages, phone calls, photos, and other personal data. It really annoys me, nor am I going to take the time to dig into the information. After seeing the device and seeing if the profile was tampered with, give HR a ring and let them know about these issues.




Find this helpful? Click the kudos button. Thanks!



Sounds like your users are deliberately trying to break things, mine are just doing it through a fluke of stupidity.  (mine or theirs, I haven't worked it out)


We don't have a HR department 🙂  Large organisation pretending it is small with a very odd management structure.  I have prepared a new iPad in the office, locked it down, tried to unlock / break it without success and have sent it to the remote user who will return their iPad.


Good Luck

It could have been one of those issues where it just stopped communicating. What symptoms caused them to contact you? Could they not receive WiFi or download apps from the Meraki MDM app? 

Find this helpful? Click the kudos button. Thanks!

When an iPad does not have an assigned user I assign it a profile called "Spare" which removes almost all the useful applications that someone would use.  This forces them to contact me so I can assign it to them and update a host of other stuff.


Without a Meraki profile, nor Safari this iPad was rendered useless.


I have modified this profile to allow access to Safari so this problem won't repeat.

If Safari was still locked from the device it most likely lost the ability to connect to WiFi and the profile could not update. Or, surprisingly, the profile got corrupted by some unknown force, rare... but it happens.

Find this helpful? Click the kudos button. Thanks!
Kind of a big deal

You could download the profile from Meraki and send him a Google Drive link to download it!

Find this helpful? Click the kudos button. Thanks!
Get notified when there are additional replies to this discussion.
Welcome to the Meraki Community!
To start contributing, simply sign in with your Cisco account. If you don't yet have a Cisco account, you can sign up.