Meraki Setting for Sonos Surround

SOLVED
Jsmittz
Here to help

Meraki Setting for Sonos Surround

am hoping someone in the Meraki community might have some guidance. I have a Sonos Arc that I’m trying to pair to a couple of Sonos Era 300 speakers as surrounds; however, the connection between the Arc and the Eras continues to drop after the initial pairing. Separately they stay connected fine, but paired the connection fails. 

 

I have tried this with the Arc wirelessly connected, hardwired into my MX, and hirewired into my MS, all ways dropped the connection. 

I’ve spent hours upon hours with Sonos tech support, including swapping my arc out, but have got nowhere. My setting should be good as I am not doing anything with VLANs, I have wireless client access set to allow, and have dual band steering enabled. 

The sonos support team seems to think the issue is with my Meraki network not allowing the Arc to broadcast their mesh network to keep the surround speakers connected. 

Has anyone else run into this or have any ideas what I could look at from my network settings?

1 ACCEPTED SOLUTION
Jsmittz
Here to help

After much trial and error, I found the solution to this. It finally hit me that the Sonos tech support mentioned that there speaker was broadcasting its own 5g signal to connect to other speaker.. The Air Marshal was containing that signal as a rouge SSID. Once I whitelisted that SSID, everything was able to work as expected. 

View solution in original post

12 REPLIES 12
rhbirkelund
Kind of a big deal

On your Meraki Switch, that's closest to your MX (one which might be considered a "Core Switch") try and enable IGMP Querier,  on the VLAN where your Sonos resides. Note that the interface IP here, is different from the Meraki Management IP! So use an address that is available.

 

Skærmbillede 2023-08-25 kl. 10.39.15.png

 

You might also want to ensure that IGMP Snooping is Enabled on your switch, by browsing to Switching -> Configure -> Switch Settings.

LinkedIn ::: https://blog.rhbirkelund.dk/

Like what you see? - Give a Kudo ## Did it answer your question? - Mark it as a Solution 🙂

All code examples are provided as is. Responsibility for Code execution lies solely your own.

Where would I find the IGMP Querier setting?

 

I did find and see that I have IGMP Snooping enabled. 

again, I’m not doing anything with VLANs and have very basic network settings. 

rhbirkelund
Kind of a big deal

Go to Switching -> Configure -> Routing & DHCP

Click on the blue "Add" button, to add a new interface on your switch.

 

Select your switch, and give the Interface a name. Any name will do.

If you're not doing anything with VLANs I'll assume you're still using VLAN 1. Enter that in the VLAN field.

Enter an available IP address in your network, which isn't currently in use. Make sure it's not handed out by your DHCP server (reserved).

In the multicast Routing, select "Enabe IGMP Snooping Querier".

Hit Save.

 

Wait a few moments for the config to download to the Switch, and try again.

 

Skærmbillede 2023-08-25 kl. 16.20.47.png

LinkedIn ::: https://blog.rhbirkelund.dk/

Like what you see? - Give a Kudo ## Did it answer your question? - Mark it as a Solution 🙂

All code examples are provided as is. Responsibility for Code execution lies solely your own.

This is probably a very novice question, but how find or create an available IP address?

 

Also, I do not have any Bonjour forwarding rules set up and in my wireless access control settings 'Bonjour forwarding' is set to 'disabled'. Would those be correct or would I need to do any thing there to allow the Arc to broadcast it's signal to the other speakers?

 

 

DanielWahlsten
Getting noticed

This is probably no help but I have tried basically everything ending up killing two office floors. My advice would be to invest in another system

than Sonos.

 

I also have access to Sonos beta and they are very aware of the issue. The last survey was about how important it would be to be able to reach Sonos between different SSID and from internet.

 

So this is probably on the way. Question is when… 

GIdenJoe
Kind of a big deal
Kind of a big deal

Be very careful with Sonos gear and it's meshing function.
Sonos is notoriously evil on networks creating mesh connection between it's devices while at the same time being connected to a wired connection effectively causing L2 loops crashing your entire network.

Secondly I have yet to encounter a Sonos that supports mDNS as a protocol to announce it's services.  Sonos always seems to only use uPNP which is a broadcast (255.255.255.255) which cannot cross any VLAN boundary.  However as you are not dealing with VLAN's the Sonos devices are probably dropping their connections on their own.  If you are tech savvy enough or know someone that is you could add a switchport mirror and effectively look at the packets.

Since traffic on Sonos has usually been unicast I don't think the IGMP snooping querier feature will do you any good.  You could also see this in the packets it is sending.  If the IP is in the range of 224. or above then you are dealing with multicast.

 

Since Sonos techs are pointing fingers to the network you would need to do the correct packet captures so you can show them facts and you can point back at them with proof.

Yeah, it’s a very odd instance because separately I have no issue connecting any Sonos speaker to my network; it is only when I try to connect the two Era speaker to the Arc speaker to be surrounds. 

when you say I would “need to do the correct packet captures”, how do you mean? Which ones should I be doing?

GIdenJoe
Kind of a big deal
Kind of a big deal

Well you should try doing a mirror capture on the port where the main station is OR on the device you want to pair.  Then start your capture and see what connections are being made.

When your pairing breaks you should see certain packets not being answered.  It is possible you will have to do captures on both sides to determine what device is not responding and check it's connection and then you will have your evidence that it is not the network that fails but the devices that just stop making a connection.  Or if the devices are trying to communicate using their mesh link instead of the switches.

 

It has been very long luckily that  I had to troubleshoot a device like that so I'm not clear what connections are actually being made so you'll have to rely and your eyes and common sense.

rhbirkelund
Kind of a big deal

There are a couple of things here that are making me think that you might want to get in touch with someone with more knowledge in networking, to help you out on a 1:1 basis.

LinkedIn ::: https://blog.rhbirkelund.dk/

Like what you see? - Give a Kudo ## Did it answer your question? - Mark it as a Solution 🙂

All code examples are provided as is. Responsibility for Code execution lies solely your own.

I am admittedly not a network engineer. I got my Meraki stack to try learning with; unfortunately I haven’t got that far though and this issue is challenging me with things I haven’t touched or dug into yet.. 

Jsmittz
Here to help

After much trial and error, I found the solution to this. It finally hit me that the Sonos tech support mentioned that there speaker was broadcasting its own 5g signal to connect to other speaker.. The Air Marshal was containing that signal as a rouge SSID. Once I whitelisted that SSID, everything was able to work as expected. 

rhbirkelund
Kind of a big deal

Well spotted! I would not have thought about Air Marshall containing the SSID.

LinkedIn ::: https://blog.rhbirkelund.dk/

Like what you see? - Give a Kudo ## Did it answer your question? - Mark it as a Solution 🙂

All code examples are provided as is. Responsibility for Code execution lies solely your own.
Get notified when there are additional replies to this discussion.
Welcome to the Meraki Community!
To start contributing, simply sign in with your Cisco account. If you don't yet have a Cisco account, you can sign up.