cancel
Showing results for 
Search instead for 
Did you mean: 

Wrong vlan applied(AP offline)

New here

Wrong vlan applied(AP offline)

Hello guys,

 

I´am using Cisco Meraki with 44 AP(MR42) receveiving DHCP from my switch-core, i recently applied the incorrect VLAN to one of these APS and lost connection(offline) with this ap, so anyone know any tactics to be recovering this AP?Haha

 

Ty guys!

9 REPLIES 9
Kind of a big deal

Re: Wrong vlan applied(AP offline)

Assuming you have set the port configuration back to the 'correct' VLAN? Try shut/no shut on that port in question to power cycle the AP. Should go back through the startup process, grab an IP on the right VLAN and start working.

Worse case you might have to perform a reset on the AP by pushing the reset button for 15 seconds.
Nolan Herring | nolanwifi.com
TwitterLinkedIn
New here

Re: Wrong vlan applied(AP offline)

Sup Nolan, 

 

I did this, now the AP has changed to "good repeater".

 

Ty 

Kind of a big deal

Re: Wrong vlan applied(AP offline)

Can you show an example of the port config on an AP that is working, and how you have it set for the port for the AP that is not working.

In addition, the network settings for an AP that is working and the AP that isn't.

Its getting power but not data based on the good repeater mode, so might just be a VLAN not being allowed.
Nolan Herring | nolanwifi.com
TwitterLinkedIn
New here

Re: Wrong vlan applied(AP offline)

Now, the AP is offline again.

 

Switch port config. to AP:
interface GigabitEthernet1/0/10
storm-control broadcast level 10
storm-control multicast level 10
port security max 10
port security mode max-addresses
port security discard trap 60
spanning-tree portfast
spanning-tree bpduguard enable
switchport access vlan 8
no macro auto persistent
no macro auto smartport

 

I applied the wrong VLAN on the AP, by meraki dashboard. I believe that only a reset will solve this.

 

Ty Nolan

Highlighted
New here

Re: Wrong vlan applied(AP offline)

vlan.png

Kind of a big deal

Re: Wrong vlan applied(AP offline)

I personally never bother with the AP network config. I like to control it from the switch port side.

Set your port to TRUNK and use native vlan X (assuming X = 9 in your case) and the AP will grab an IP from the VLAN that you configure on that port as native. Then you leave that network config on the dashboard just as you see it. DHCP and no vlan configured

Nolan Herring | nolanwifi.com
TwitterLinkedIn
New here

Re: Wrong vlan applied(AP offline)

My Switch core use this config:

ip dhcp pool WIFI-AP-MERAKI
network 10.1.1.0 255.255.255.0
default-router 10.1.1.10
dns-server 8.8.8.8 208.67.220.220 208.67.220.222
!

interface Vlan8
description ## VLAN AP-MERAKI ##
ip address 10.1.1.10 255.255.255.0
!

------------------------------------------

My access-switch(AP port) use this:

interface GigabitEthernet1/0/10
storm-control broadcast level 10
storm-control multicast level 10
port security max 10
port security mode max-addresses
port security discard trap 60
spanning-tree portfast
spanning-tree bpduguard enable
switchport access vlan 8
no macro auto persistent
no macro auto smartport

 

My core is connected with all other switches, doing the distribution of this DHCP.

 

I've always used the AP without vlan and only with DHCP seted, it works fine.
Due to an error I put vlan = 8 on the AP, losing total connection...
you are suggesting that, I put the PORT as trunk for use of the native vlan?

 

Kind of a big deal

Re: Wrong vlan applied(AP offline)

You can do it the way you've been doing it if you want to. I think you said you have 43 other access points all working this way?

With trunking, it will allow you to have multiple SSID's getting dropped off onto different vlans. Like corp on vlan 10 and guest on vlan 20 etc. If your using bridge-mode on the SSID in question.

I wouldn't want you to change how your doing this for just 1 AP though, if it works on 43 other ones.

Did you try to perform the reset using the normal port configs (the same as all the other AP are using)?
Nolan Herring | nolanwifi.com
TwitterLinkedIn
Kind of a big deal

Re: Wrong vlan applied(AP offline)

You have configured port security to limit the number of MAC addresses allowed on the switch port "port security max 10".

 

You don't want that feature enabled for an AP port.

Welcome to the Meraki Community!
To start contributing, simply sign in with your Cisco account. If you don't yet have a Cisco account, you can sign up.