cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 

VLAN DHCP Issue with WAP clients only

Highlighted
Here to help

VLAN DHCP Issue with WAP clients only

Hello,


I am having an issue contacting a DHCP server only when connecting from an access point on our new VLAN.

 

We set up a small satellite office and set it to use VLAN 10.  We have it set up as follows:

 

An MX100 set up with subnet of 192.168.135.0/24, MX IP of 192.168.135.254, and VLAN ID: 10.

Port 2 on the MX is set up as an access port on VLAN 10.

That port is connected to a MS225 port that is an Access on VLAN 10 also.

The MX is set up as a DHCP server and works fine with any wired clients on the MS225.

Each port on the MS225 is tagged as access VLAN 10.

The WAP is a MR42, set with only one SSID, which is set to tag traffic as VLAN 10.

I am seeing errors in the VLAN request status on the LAN tab of the access point.


I see for VLAN 10 5/5 DHCP failures

I also see UNTAGGED VLAN it says 0/5 DNS failures.

 

I am not sure what my issue could be.  Any ideas of what to try here?

 

Thanks!

-Eric

 

4 REPLIES 4
Highlighted
Kind of a big deal

Re: VLAN DHCP Issue with WAP clients only

What is the IP of the MR? Why not set the switchport on MS to "trunk" so that VLANs can carry over?

Highlighted
Here to help

Re: VLAN DHCP Issue with WAP clients only

So I think I actually figured out the issue minutes after posting this.  It may have been because of tagging traffic on the VLAN multiple times...


The switch port was set as an access port on VLAN 10, and the SSID was set to tag traffic on VLAN 10.  I took off the tagging SSID side, and was able to obtain an IP address.

 

I'm just wondering if this is the ideal config?

Highlighted
Kind of a big deal

Re: VLAN DHCP Issue with WAP clients only

'ideal' is dependent on the design. It's perfectly viable if your only ever going to have a single SSID with a single VLAN.

I personally prefer to always have my AP's connecting to a TRUNK port, and then choosing which VLAN's to allow across it for pruning and this also gives me the ability to create new SSID's on different VLANs, allowing for growth and more flexibility on what you can do.
Nolan Herring | nolanwifi.com
TwitterLinkedIn
Highlighted
Kind of a big deal

Re: VLAN DHCP Issue with WAP clients only

If your tagging the VLAN on the SSID Access-Control settings, then set the port the AP is on to TRUNK and allow VLAN 10 across.

Otherwise I believe if you don't tag the SSID settings, you can set the AP to access on VLAN 10 and it should work.

I would also test another port on VLAN 10 just to make sure everything works DHCP wise
Nolan Herring | nolanwifi.com
TwitterLinkedIn
Welcome to the Meraki Community!
To start contributing, simply sign in with your Cisco account. If you don't yet have a Cisco account, you can sign up.