Streaming TV's pixelating

macsolutions
Here to help

Streaming TV's pixelating

Need some help trying to fix Smart/streaming TV's pixelating. TV's are Samsung "The Frame" if it matters.

 

Area / location might be important to this: Old Town, Alexandria, VA. Old homes & buildings (some of them hundreds of years). Property records say the home was built in 1978, but I'm not sure how true this is - could have been 2 houses put together as is common for larger homes in the area. Slightly less than 3 miles from the tip of Washington Reagan Airport, but out of the actual flight path by about 2/3 mile.

 

Network is wireless only, 3 x MR36. Second floor device is the wired one.

 

Basic Indoor Profile has been edited to allow for band steering, minimum bitrate on 2.4GHz is 24, and minimum bitrate on 5GHz is 12

 

macsolutions_5-1640702266532.png

 

macsolutions_6-1640702446155.png

 

 

 

macsolutions_0-1640701711974.png

macsolutions_1-1640701737772.png

TV 1

macsolutions_3-1640702160973.png

 

TV 2

macsolutions_4-1640702231403.png

 

TV 3

macsolutions_2-1640702106214.png

 

7 REPLIES 7
MerakiDave
Meraki Employee

Sounds like it could be a difficult RF environment causing it, but then again, it's not like the APs or the TVs are moving.  The RF environment can still change of course, the trick may be finding what other variables we have since the equipment is stationary.  Where are the APs in relation to the TVs and what is in between them?  How often is the pixelating an issue, is it fairly frequent, or any particular rhythm to it, or it's only on occasion and completely random? 

 

Also curious that all 3 APs landed their 5GHz radios on channel 44 when the RF profile is set for auto channel.  You're close enough to DCA there's the radar question, do you have DFS channels enabled?  And if you look at each AP's list of clients, what are the client TVs actually connecting to, 2.4 or 5?  When you look at the TV's client page, what are its capabilities and SNR? 

 

Perhaps toggle a few things such as making the SSID 2.4GHz vs 5GHz only for a period of time, and on the 5GHx side perhaps manually setting 20MHz channels and manually set 3 non-DFS channels like 36, 44 and 153 for example. 

ww
Kind of a big deal
Kind of a big deal

What are you playing on it when this happens? Do you see it on all streaming services? Are you sure its a wireless issue and not wan bandwidth?

Ryan_Miles
Meraki Employee

2 APs are repeaters. So, them all being on channel 44 is ok and means it's the mesh back haul.

 

Are the TVs running their latest available firmware? What streaming app is in use? Are there multiple streaming apps in use on the TV (ex. youtubetv, hulu, hbo, etc)? If yes do they all exhibit streaming issues?

 

As another asked are the TVs always connecting on 5GHz? Also, you might test a lower min bit rate and also test disabling band steering. I generally don't see issues with modern devices and band steering, but you never know.

 

What's the rest of the SSID config? What addressing mode and the L3 firewall rule is set to allow correct?

MerakiDave
Meraki Employee

Oh yeah good catch @Ryan_Miles I looked right past the repeater status icon, so that's ok.  But, @macsolutions are any/all of the TVs running off one of the repeater APs, and could the AP they're connected to be 2 mesh hops away?  So with the responses so far, we've asked a ton of questions, let us know your thoughts and the details of the physical setup and SSID config, firmware versions (both TVs and APs), etc. 

GIdenJoe
Kind of a big deal

A few initial things I notice in your deployment.
- Your AP's are sending at max power (23dBm) which means there are too few neighboring AP's visible
- Only 1 AP per floor and there are multiple rooms?  Then that means your AP is probably in the hallway which is usually a bad design.
- 2 AP's are indeed in repeater mode which causes more channel contention.

- Minimum bitrate should be carefully designed especially on the 5 GHz band since that should be the band of choice for streaming.

Then a question: is the streaming service like a netflix type of individual streaming or are you talking about a local multicast streaming service?  In the latter case make sure you have multicast to unicast conversion.

Be sure to also check your clients per AP and look at their signal quality.  That value is in dB and denotes the upstream SNR.  If it is lower than 25 dB your client it not in a good spot to connect but because your AP's are sending in full power you probably see full signal bars on the tv sets.  This will worsen the situation by causing alot of retransmits.  Try limiting the signal power of the AP to 14 dBm and see how many bars you now have on your TV set.  If it is too low you probably should reposition or add more AP's.

 

If you have no option of cabling the other AP's and must continue to use mesh mode then you'll need to make sure the mesh AP's themselves have sufficient quality of signal towards the root AP.

PhilipDAth
Kind of a big deal

So many possibilities.

 

If it was me, I would be trying to see if I could get the other two floors wired.  I'd be looking at something like an Ethernet-only AV2 power line extender, so you can run a wired network over the power cabling already in the house, and then plug the APs into those.

 

I've had good results using the D-link power line extenders.

GIdenJoe
Kind of a big deal

Hey Philip, I have nothing against powerline extenders as a technology by itself because it's basically modulating demodulating like Wi-Fi but over electrical wiring.  However care must be taken with older electrical installations as they tend to have alot of fluctuating noise that causes those connections to be unreliable.  Even having some DC powered device with a low quality adapter even on a different circuit can wreak havoc on powerline homeplugs.

My previous job was as a technician troubleshooting home installations for an ISP and my experiences were really bad with those things.

Usually a good wireless mesh solution or even a signal modulator over coax can give better results but this all depends on the situation at hand.

 

For the OP I would strongly suggest getting cables to the other AP's and even do a little site survey to see if the AP signals are OK in both directions.

Get notified when there are additional replies to this discussion.
Welcome to the Meraki Community!
To start contributing, simply sign in with your Cisco account. If you don't yet have a Cisco account, you can sign up.