SMS Authentication Issue

SOLVED
s4mmy
Here to help

SMS Authentication Issue

Hi All,

 

We have an issue that has been raised by some of our branches re our guest WiFi which uses the SMS authentication.

 

Users are prompted to enter the authorization code that had been SMS'ed to them, but when they leave the splash page and go to the messages app to retrieve the code the screen to enter the code is gone and they need to request a new code, so they enter a loop. This has been reported and tested on iPhone, i haven't done any testing on Android.

 

The only "work around" we have at the moment is to do the drag down to preview the message, this isn't however ideal for all users.

 

Any thoughts?

 

Cheers

1 ACCEPTED SOLUTION

Hey Gallon,

 

We figured out a fix for this.

 

Under Wireless > Access control about halfway down the page there is a drop down for "Walled garden" when you have a splash page enabled. You should set this to "Walled garden is enabled" and put the "*.apple.com" domain in the "Walled garden ranges" section.

 

Then all is right in the world!

View solution in original post

5 REPLIES 5
Lucas_Kramer
Here to help

This worked before seamlessly? Is it just 1 user of multiple who're having this problem? 

 

First thought it seems like a cache problem between Twilio (or other 3rd party SMS provider) and the Meraki API. Have you raised a ticket with support?



Anima Sana In Corpore Sano
helpful comment? Get me some kudos 🙂
GALLON
New here

I´m currently facing the same Issue here...

 

 

Hey Gallon,

 

We figured out a fix for this.

 

Under Wireless > Access control about halfway down the page there is a drop down for "Walled garden" when you have a splash page enabled. You should set this to "Walled garden is enabled" and put the "*.apple.com" domain in the "Walled garden ranges" section.

 

Then all is right in the world!

PG
Just browsing

Hi!  We are facing the same issue with SMS and Iphones, users go to messages and loose the splash page.

 

What i dont understand i how your solution makes this work. cannot see the link between loosing the splash page and accessing the "*.apple.com" in the walled garden.

 

We tried it with no luck

 

thanks!

So this is an old thread, but I wanted to explain the issue for others looking into this, because I keep running into it myself during customer integrations.

 

1) With walled garden disabled, the IOS device will http (port 80) back to Apple, and Meraki will intercept that and serve the splash page. User enters their phone number, and if they miss the text and exit the captive portal assistant browser, IOS drops them from WiFi. When they reconnect, they start the process again with Meraki asking for their phone number, and are stuck in a loop. Meraki should have an option on the page "if you already have a code, please enter it here" as an option.

2) If you use the walled garden and add *.apple.com, the phone joins the WiFi but will not get redirected to the Meraki splash page automatically, since the captive portal assistant is able to phone home to Apple successfully. The user then opens Safari, and (as of 2022) normally won't get redirect either, because most web sites are https (port 443), and Meraki won't/can't redirect 443. If you enter a web site manually like neverssl.com or example.com, the IOS device will attempt an http (port 80) connection and you will be redirected to the splash page.

Get notified when there are additional replies to this discussion.
Welcome to the Meraki Community!
To start contributing, simply sign in with your Cisco account. If you don't yet have a Cisco account, you can sign up.
Labels