cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 

Non-domain devices are not resolving DNS to local servers, missing the DNS suffix

SOLVED
Highlighted
New here

Non-domain devices are not resolving DNS to local servers, missing the DNS suffix

Does anyone know of a way to successfully push DHCP option 15 to non-domain devices on a wireless SSID using NAT-mode without manually configuring the DNS suffix in the wireless adapter properties?

 

We have a NAT-mode configured SSID with access control allowing wireless clients to access internal resources.  We can ping our main DC01 server just fine by IP address.  We were not able to ping by resolving the DNS name of our server, but I was able to find the custom DNS servers under the content filtering drop-down option.  We were still unable to resolve DNS names, but after contacting support we were able to find that the NDS suffix was not being added.  By adding the DNS suffix manually in the wireless adapter properties, the wireless device was able to resolve the DNS name of our DC01 server no problem.

 

Now I didn't want to configure every non-domain device manually, so after a short bit of research I found that DHCP option 15 should configure the DNS suffix.  Here is where I'm getting stuck, this option was already configured in our DHCP options. So I'm stuck.  I'm going to start configuring some of these devices manually (there's not too many of them), but I was hoping someone may know if I'm missing something, or able to point me in the right direction.

 

Thanks,

- Greg

1 ACCEPTED SOLUTION

Accepted Solutions
Head in the Cloud

Re: Non-domain devices are not resolving DNS to local servers, missing the DNS suffix

You don't have control of the DHCP server options when you use NAT mode.  Normally NAT mode is for guests, why are you not using bridge mode and then you can use your own DHCP server or the one in the MX appliance if you have one?

3 REPLIES 3
Head in the Cloud

Re: Non-domain devices are not resolving DNS to local servers, missing the DNS suffix

You don't have control of the DHCP server options when you use NAT mode.  Normally NAT mode is for guests, why are you not using bridge mode and then you can use your own DHCP server or the one in the MX appliance if you have one?

New here

Re: Non-domain devices are not resolving DNS to local servers, missing the DNS suffix

We are running out of IP addresses on our LAN.  We will be breaking up devices and locations into different subnets soon, but as of right now everything is on the same network.  So it looks like I'm stuck updating them manually if we are using NAT-mode?

Kind of a big deal

Re: Non-domain devices are not resolving DNS to local servers, missing the DNS suffix

The other option is to access servers via their FQDN.  For example, rather than accessing \\server used \\server.domain.local.

 

Note, depending on your DNS setup, you may need to use a trailing "." (which turns it into an absolute DNS lookup rather than a relative lookup).

Welcome to the Meraki Community!
To start contributing, simply sign in with your Cisco account. If you don't yet have a Cisco account, you can sign up.