Missing notification on expiring SSID authentication

Fabian1
Getting noticed

Missing notification on expiring SSID authentication

Hi everyone,

 

we have a SSID with Google credential login. So when you connect to the WiFi, and you try to get a website, the google login page comes up and you have to type in your credentials.

 

But when the authentication expires, the user can not reach any website but google, because it is on the whitelist to get the login page. No notification comes up to the user, that they have to login again. The worst thing is, that you have to surf to a website that the user did not open for a long time, I guess because of hsts. Than the redirect works again.

 

How is it possible to get the user directly to the google auth page when the Wi-Fi authentication expires? But a push notification or simply a redirect to the google website?

 

Any ideas? 

 

Thank you 🙂

4 REPLIES 4
Speedbird1
Here to help

I am surprised no one has replied here.

I have seen exactly the same behaviour on the Meraki cloud authentication option to. 

Where after the set time out the login splash does not appear for client to re-login. 

 

Users have to forget the network and re-add it

 

The reason i have been told by Meraki is because - "The splash page is only generated when HTTP traffic is sent by the client" 

 

Note the term HTTP and not HTTPS.

 

Dear Meraki I have had this out with your support team ... PLEASE find me a device that sends HTTP traffic by default for the splash page to re-appear after the set timeout. There isn't one !!!! 

 

I have also been told by a Support manager there is no roadmap to change this behaviour.

 

Causing us a lot of pain to be honest.

 

 

KarstenI
Kind of a big deal

Redirection to a captive portals will always give a certificate warning if HTTPS is redirected. That is the reason that nowadays only HTTP is redirected because no redirection is still better than redirection to a warning-page.

HTTP is by default used for the captive-portal detection that is included in many operating systems. If it does not pop up automatically, I tell the users to browse to a site like neverssl.com which on purpose only uses HTTP.

Thanks

 

That is interesting, maybe its just the way Meraki support handled my case and told me it is what is so deal with it.

 

(Sorry to hijack this thread OP but i was going to create my own)

 

How do you tell 500+ users to go to a non HTTPS site to get re-authenticated, must be something else we can do to force them to a non HTTPS page so they get the splash page up.

 

 

 

 

I'm thinking something had to change with Meraki, Being redirected to the splash page was working just fine until a week or so ago. Now all of a sudden after the timer I as well stopped getting the redirect. Have to disconnect the wifi and reconnect, and manually open a browser and go to nasa.gov to be redirected.

Get notified when there are additional replies to this discussion.
Welcome to the Meraki Community!
To start contributing, simply sign in with your Cisco account. If you don't yet have a Cisco account, you can sign up.