Meraki Wireless API can't find a way to change the Outdoor per SSID bitrate.

SOLVED
Egon
Conversationalist

Meraki Wireless API can't find a way to change the Outdoor per SSID bitrate.

Hello,

My problem is that I am unable to change the minimum bitrate on the Outdoor RFProfile.

I am using the Meraki API v1 and the Python Meraki Library 1.15.0

When I try to use the PUT function /networks/{networkId}/wireless/rfProfiles/{rfProfileId}

And give it the perSSidSeetings key with the desired minBitrate I get a 200 code back but it does not change anything. 

When I use the function /networks/{networkId}/wireless/ssids/{number} it only updates the Indoor RFProfile and not the Outdoor one.

 

Thank you for taking a look at this and any light that can be shed on this can be appreciated.

 

 

1 ACCEPTED SOLUTION

Here's the complete JSON I'm sending when I do an update to the RF profile and set min data rates on 4 SSID's.

 

{
"name": "***RYAN TEST***",
"bandSelectionType": "ap",
"clientBalancingEnabled": "true",
"minBitrateType": "ssid",
"apBandSettings": {
"bandOperationMode": "dual",
"bandSteeringEnabled": "true"
},
"twoFourGhzSettings": {
"maxPower": "11",
"minPower": "8",
"minBitrate": "12",
"validAutoChannels": [
"1",
"6",
"11"
],
"axEnabled": "true"
},
"fiveGhzSettings": {
"maxPower": "14",
"minPower": "8",
"minBitrate": "18",
"validAutoChannels": [
"36",
"40"
],
"channelWidth": "auto"
},
"perSsidSettings": {
"0": {
"name": "meraki-cameras2",
"minBitrate": 11,
"bandOperationMode": "dual",
"bandSteeringEnabled": true
},
"1": {
"name": "meraki-camera",
"minBitrate": 24,
"bandOperationMode": "dual",
"bandSteeringEnabled": true
},
"2": {
"name": "meraki-camera",
"minBitrate": 36,
"bandOperationMode": "dual",
"bandSteeringEnabled": true
},
"3": {
"name": "meraki-camera",
"minBitrate": 54,
"bandOperationMode": "dual",
"bandSteeringEnabled": true
}
}
}

View solution in original post

8 REPLIES 8
Ryan_Miles
Meraki Employee

You're trying to edit the default outdoor profile? Try creating a new custom outdoor profile and see if the call works on there. From what I've seen the two default indoor and outdoor profiles don't allow all the same API calls against them.

Egon
Conversationalist

First, thank you for the reply.

Here are some more details.

Yes I would like to edit the default outdoor RFProfile minBitrate. 

I would settle for being able to edit the minBitrate on a RFProfile of my choice. 

Here is what I am seeing:

So here I have created a Outdoor custom RFProfile and did not make it default. For right now I just want to change the min bitrate for the number 0 SSID. I am using the following python calls:

 

profiles = dashboard.wireless.getNetworkWirelessRfProfiles(

    network_id,

    includeTemplateProfiles=False)

 

for profile in profiles:

    if (profile["name"] == "Custom Outdoor Profile"):

        input_minBitrate = {"minBitrateType": 'ssid',

         "perSsidSettings":{'0':{"minBitrate":9}

            }

            }

        return_value = dashboard.wireless.updateNetworkWirelessRfProfile(

            network_id,profile["id"],

            **input_minBitrate)

        pprint.pprint(return_value)

 

The return value contains:

'perSsidSettings': {'0': {'bandOperationMode': 'dual',

                           'bandSteeringEnabled': True,

                           'minBitrate': 1,

So the min bitrate is still 1 not 9 like I wanted.

 

If I use the function updateNetworkWirelessSsid there is no way to specify what RFProfile I would like to target. And it only changes the Indoor default profile whether that is one that was there by default or the one that I created as far as I can see there is no way to change the Outdoor profile minbitrate from the API.

This has just recently become an issue when these settings were moved to the RFProfile menu from the SSID edit menu.

Ryan_Miles
Meraki Employee

I just tested this albeit using Postman, but it allowed me to change the SSID bitrates. I used the PUT/networks/{networkId}/wireless/rfProfiles/{rfProfileId} endpoint

Egon
Conversationalist

Yes I can set the minBitrate for all SSIDs at the same time. But I would like different SSID's to have different Minimum bit rates.

Setting different min bit rates for multiple SSID's is working for me.

 

In your put you're adding the relevant SSID number beyond just "0" yes?

Egon
Conversationalist

No I just the one. What does your data structure look like when you send the put function?

Mine just loosk like this:

{"minBitrateType": 'ssid',

         "perSsidSettings":{'0':{"minBitrate":9}

            }

            }

 

How much do I need to include in the body of the request. And is there any documentation you can point too.

Here's the complete JSON I'm sending when I do an update to the RF profile and set min data rates on 4 SSID's.

 

{
"name": "***RYAN TEST***",
"bandSelectionType": "ap",
"clientBalancingEnabled": "true",
"minBitrateType": "ssid",
"apBandSettings": {
"bandOperationMode": "dual",
"bandSteeringEnabled": "true"
},
"twoFourGhzSettings": {
"maxPower": "11",
"minPower": "8",
"minBitrate": "12",
"validAutoChannels": [
"1",
"6",
"11"
],
"axEnabled": "true"
},
"fiveGhzSettings": {
"maxPower": "14",
"minPower": "8",
"minBitrate": "18",
"validAutoChannels": [
"36",
"40"
],
"channelWidth": "auto"
},
"perSsidSettings": {
"0": {
"name": "meraki-cameras2",
"minBitrate": 11,
"bandOperationMode": "dual",
"bandSteeringEnabled": true
},
"1": {
"name": "meraki-camera",
"minBitrate": 24,
"bandOperationMode": "dual",
"bandSteeringEnabled": true
},
"2": {
"name": "meraki-camera",
"minBitrate": 36,
"bandOperationMode": "dual",
"bandSteeringEnabled": true
},
"3": {
"name": "meraki-camera",
"minBitrate": 54,
"bandOperationMode": "dual",
"bandSteeringEnabled": true
}
}
}

Egon
Conversationalist

Thank you adding in all of the SSIDs into the body worked for me.

Get notified when there are additional replies to this discussion.
Welcome to the Meraki Community!
To start contributing, simply sign in with your Cisco account. If you don't yet have a Cisco account, you can sign up.
Labels