cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 

Meraki MR42 client jumps to distant AP

SOLVED
Here to help

Meraki MR42 client jumps to distant AP

Hello,

I currently use 3 Meraki MR42 APs for our enterprise WLAN network, one on the first floor of the building, and the others on 3rd floor and 4th floor. The problem is that some clients from the first floor AP jumps to the 3rd floor AP or even the 4th one.

The signal of those client goes from 40-50dB (when connected to the closest AP) to 13-17dB (when connected to distant APs).

If I look through the log of the clients that report the problem, I just see that they roam between APs even thou they don't move they're equipment at all. The logs just tell me:

 

  • WPA authentication
  • Multiple DHCP servers detected
  • 802.11 association
  • 802.11 disassociation
  • WPA deauthentication
  • And the loop continues couple of times

I always keep the APs up-to-date but the problem still persisted for couple of months. Also the equipment (MacBook-Pro) has the OS freshly installed.


Does anyone have any idea why are the clients roaming from the closest AP to the distant ones? Or it is possible to enable more layer2 logging?

1 ACCEPTED SOLUTION

Accepted Solutions
Highlighted
A model citizen

Re: Meraki MR42 client jumps to distant AP

If you go to "Wireless > Radio settings" and view your profile do you have client balancing turned on? I wonder if that is causing that behavior as it tries to balance the number of clients associated to APs.

5 REPLIES 5
Kind of a big deal ww
Kind of a big deal

Re: Meraki MR42 client jumps to distant AP

"As a wireless client roams in an area covered by Meraki APs advertising the same SSID, it will try and associate to the AP that provides the strongest signal. The wireless adapter on the client device measures the RSSI on received frames sent by APs in order to make roaming decisions"

 

the clients with this behaviour  are only macbooks? look into the driver and roaming settings. of the device.

are they switching also between radio's or ap's on the same radio(from 5ghz to 5ghz) 

you can try set higher minimum bandwidth, or lower the ap radio signal?

 

Highlighted
A model citizen

Re: Meraki MR42 client jumps to distant AP

If you go to "Wireless > Radio settings" and view your profile do you have client balancing turned on? I wonder if that is causing that behavior as it tries to balance the number of clients associated to APs.

Here to help

Re: Meraki MR42 client jumps to distant AP

Thank you for your reply,

Yes, the client/s with the problem are MacBooks.
They switch between AP's with the same radio (5GHz to 5GHz), rarely they switch between APs and radios.
The "Dual band operation with Band Steering" option is also enabled as it is very useful and I use a minimum bitrate of 36 Mbps.
The transmission power is set to 15dB, but I do not really want to set it any lower, as some distant clients may have connectivity problems after.

Is there any way to export more detailed logs about what is happening on OSI Layer 2? (Will SNMP do this?)
And can you force a client from the Meraki dashboard to connect to a specific AP from the WLAN?

Thank you

Here to help

Re: Meraki MR42 client jumps to distant AP

Thank you for your reply,

I have checked the radio profile as suggested, and the client balancing option was turned on indeed. I just used the default indoor profile for radio settings. The AP was indeed a bit more busy than usual when the "random roaming" happened, but it had only a maximum of 39 clients. From the official documentation I understood that this model of AP can easily support 50 clients. Also during that period I have checked the channels utilisations and it was no more the 50% on 2.4GHz and 30% on 5GHz.

 

I will look closely to this option and maybe disable it, but I am also interested in the actual metrics of the APs.

Thank you!

Getting noticed

Re: Meraki MR42 client jumps to distant AP

I had a similar issue and turning off Client balancing solved the problem.  Its worth turning off to try it.

Welcome to the Meraki Community!
To start contributing, simply sign in with your Cisco account. If you don't yet have a Cisco account, you can sign up.