Meraki AP not getting IP through DHCP

Naresh_Bhardwaj
Getting noticed

Meraki AP not getting IP through DHCP

Hi All

 

Meraki AP is not getting IP address through DHCP .

I have removed that LAN cable from Meraki AP and connect it to Laptop directly DHCP is working fine, and Laptop is getting IP address from correct Subnet.

 

Not sure why Meraki AP is not getting IP through DHCP and its giving me "AP is a repeater" under LAN IP.

 

Naresh_Bhardwaj_0-1615881433627.png

 

Also can someone suggest if put static IP in the Meraki AP the Meshing should enable or Disable

 

5 REPLIES 5
antonis_sp
Building a reputation

When the AP is in repeater mode, it does not get a LAN ip.

If the AP should not be a repeater, cabling is usually the problem.

If the AP is connected to the switch directly (with a short patch cord), does it show the same problem?

Hi ,

 

Thanks

 

How to disable repeater mode of Meraki AP 

ww
Kind of a big deal
Kind of a big deal

Network-wide > general

Look there for "meshing"

@Naresh_Bhardwaj, disabling the Meraki mesh functionality is unlikely to solve your problem. The AP is going into Repeater mode because it’s not getting an IP address from a DHCP server. Disabling mesh will just mean if it can’t get an IP address it will effectively do nothing.

 

You’ll need to do a packet capture on the link between the AP and the switch to troubleshoot the issue - see if proper DHCP request and response packets are being sent. If it is a new AP then it is entirely possible that the Ethernet interface is faulty, but you’ll need packet captures to confirm that.

jmoake
Getting noticed

When I configure APs, I make sure the switch port the AP is connected to is configured for access mode, on a VLAN that has DHCP, and has access to the internet.  I usually use a vlan configured for user desktop PCs.  

Get notified when there are additional replies to this discussion.
Welcome to the Meraki Community!
To start contributing, simply sign in with your Cisco account. If you don't yet have a Cisco account, you can sign up.