MR36 Client Roaming Issue

SOLVED
lloydz
Just browsing

MR36 Client Roaming Issue

Hi all - we are a school district who just upgraded all of our wireless infrastructure from Cisco 2602i APs to Meraki MR36 APs. Apologies in advance as we are still new to Meraki. 

 

We have APs in every classroom - we've recently discovered that in some locations (not all), student and teacher devices (mixture of Chromebooks and Windows devices) are holding connections to remote/adjacent room APs, rather than connecting to the AP in the room. This is especially prevalent in the middle/high schools where students move regularly. Even restarting the device will not force it to authenticate to the local AP in the room.

 

I've adjusted the radio profile on our APs for a minimum of 18Mbps data rate on both the 2.4 and 5ghz bands. Meraki has "Client Balancing" enabled by default, which sounds like a great idea, but I'm wondering if this is causing the issue. Oddly, one of the APs in question only has 2-3 clients connected to it, while adjacent APs have 20-30 clients despite being in a room full of devices.

 

Any ideas on further troubleshooting?  Thank you!

1 ACCEPTED SOLUTION
KarstenI
Kind of a big deal

Which channel does the AP with the low amount of clients use? If it’s 144, there are still some clients that do not support this channel and can’t connect to it.

View solution in original post

6 REPLIES 6
RSU21it
Here to help

I would definitely start by disabling Client Balancing then be sure to manually assign channel and power on each AP radio (disable 2.4 if possible in your environment).  You may find in your environment (as I did in my school district) that if the 2.4 band is required, you will need to greatly reduce the power on the 2.4 radio.

 

You will have to determine what works for you but in my environment for example, I use a baseline power setting of 3db on the 2.4 radio and 12db on the 5 radio to get a cell size that works quite well for our high density AP deployment.  I should say that I also disabled Band Steering.

 

You mileage will vary based on your environment but hopefully you will be able to find a baseline setup and then make small tweaks from there.

Well, disabling client balancing did not fix the issue.

 

Here's where it gets interesting.  We had a spare AP that we've just replaced that problem room with, and all seems fine now.  Clients are roaming and connecting as expected.  Now the question is - was something wrong with the AP and if so, how would I even begin to explain that to support?  Everything appeared fine on the dashboard, but clients just refused to roam to it.

I've definitely had AP with bad radios over the years.  If you haven't done so already, do a factory reset on that suspect AP (https://documentation.meraki.com/General_Administration/Support/Resetting_Cisco_Meraki_Devices_to_Fa...) and if possible, move it to a completely different location to test general connectivity and roaming.

 

I would also recommend contacting support and have them monitor these roaming attempts in real time.  They will assist with packet capturing which may shed some light on the issue but again, I would do a factory reset on that AP first.

GIdenJoe
Kind of a big deal

Hey, if you want to up your minimum data rate don't use in between values like 9 or 18 Mbps.

Stick with 12 or 24 Mbps, that is usually supported better by clients.

 

To see why a certain AP is being avoided you'd really need to take some OTA captures on the channel that AP is at and see what happens when clients:
- probe for the SSID

- try to auth or assoc to the AP

- clients ask for 802.11v or k information

KarstenI
Kind of a big deal

Which channel does the AP with the low amount of clients use? If it’s 144, there are still some clients that do not support this channel and can’t connect to it.

View solution in original post

I think you might be on to something here.  After spot checking our locations, we have no Chromebooks connected to any AP that auto selected channel 144.  We're going through and modifying the RF profile to remove that channel now.

Get notified when there are additional replies to this discussion.
Welcome to the Meraki Community!
To start contributing, simply sign in with your Cisco account. If you don't yet have a Cisco account, you can sign up.