MR20 and PS4 unable to connect

Comes here often

MR20 and PS4 unable to connect

we recently swapped out a site that had MR18's installed, we replaced these MR20's.


Since the upgrade we have had 2 users with PlayStation 4's saying that they are now not able to connect to the network.


The network is setup ujsing Meraki Auth. We have whitelisted both devices, which hasn't resolved the issue.


we have created a simple network with a WPA key on each of the access points, again the PS4's are unable to connect, the eventlog shows the devices connect for a few seconds and then disconnect, the PS4's say they are unable to obtain an IP address. we have tried bridge mode and NAT mode. we have even enabled the 2.4Ghz radio only and they are still not able to connect.


Any ideas.






Kind of a big deal

For testing's sake try whitelisting the PS4 MACs.  Also under the SSID you may want to verify it is configured as such for max compatibility. 



EDIT:  Under Wireless>Radio Settings you may also want to turn off 'Client balancing'

If this was helpful click the Kudo button below
If my reply solved your issue, please mark it as a solution.
Comes here often



they are both already whitelisted and below is the compatibly level



Getting noticed

Interestingly enough I had a similar issue, I've no idea what caused it but I wiped the PS4, installed the latest firmware and it worked fine from then on. No changes made to the network.

Kind of a big deal

@RCaldicott interesting... I wonder if the PS4's do something silly like store the BSSID of the wireless network they connect to, and then only connect to that BSSID? If that were true then swapping out AP's would certainly give them issues. I don't have a PS4 to test on, but perhaps just deleting the saved wireless network, and then re-adding it would fix it?

Unfortunately that didnt work, which is why I went the whole hog and wiped the PS4, perfectly fine now though... very odd.
Comes here often

I created a new SSID with a different name and it still wasn't able to connect to that either




This is an end user device rather than my own so not sure they will be keen to try this, what will they lose? I'm not a gamer 



Nothing, PS4 stores all saves in the cloud. Sure there's a bit of a setup when it's reloaded but worth a punt IMO

Could be the load balancing on the APs. Depending on what profile is set up, it is possible that the PS4s being dropped due to the AP reaching the max number of clients.

There is only ever a couple of devices connected so I dont think it is that


I have managed to get hold of the old MR18 and a PS4 in our office , so I am going to add the MR18 back into the dashboard and connect the PS4, then I am going to add another MR20 and try and get the PS4 to connect and see what happens



Hey @brandsj


I would say, if you can, take a few packet captures as well while you do it, they might give you an indication of what the access point is telling the PS4 to do (a pcap rather than just checking the output on the dashboard is preferable as it give you more details). 


You could also try creating a new SSID with Open authentication and with minimum bitrate set to 1, then go to the Radio settings and create a new profile and disable client balancing. If that works it would be a good starting point to find out which configuration is causing the problem.




Please keep in mind that what I post here is my personal knowledge and opinion. Don't take anything I say for the Holy Grail, but try and see!
Appreciate who helps and be respectful of every opinion and every solution offered.
Share the love, especially the Meraki one!
Get notified when there are additional replies to this discussion.
Welcome to the Meraki Community!
To start contributing, simply sign in with your Cisco account. If you don't yet have a Cisco account, you can sign up.