Keep a subset of known devices from associating with a particular AP?


Keep a subset of known devices from associating with a particular AP?

I have a deployment of numerous APs in a multi-level structure made of steel/concrete/concrete blocks.  One area in particular, there is some overlap from the AP devices are SUPPOSED to connect to, and an AP from the floor below.  


On occasion, the devices will associate with the 'interfering' AP instead of the AP they are supposed to.  I can't lower output on the 'interfering' AP because it needs every ounce of power to cover the area it is designated to cover, I can't adjust the RSSI on the client devices, and I can't remove the SSID from the 'interfering' AP because it is needed in the area it covers. 

Is there any way I can just prevent these 7 client devices from associating with that 'interfering' AP?  Like a block list that only applies to one AP?  Will that even work, or will the clients just see the signal, try to associate, and basically end up in the same boat?

Getting noticed

Welcome to the world of Wi-Fi! I hate to say it, but that will probably cause more issues then anything else. If the device sees that as the recommended AP it will keep attempting to connect to it because the device doesn't know its been blacklisted. Your best option is to review your AP placement and adjust power levels, maybe even bring in a 2nd AP to serve the area.

You could also make an SSID per floor, but that will become a problem if devices move. 


you could check out the new RX-SOP.    from the docs "By reducing the cell size, we ensure that clients are connected to the nearest access point using the highest possible data rates. This is ideal for high-density environments such as stadiums and large auditoriums, where there are a large number of client devices connected per AP. "


RX-SOP is only supported on 802.11 ac Wave 2 APs i.e. MR30H/33/42/52/53/74/84/42E/53E starting firmware version MR25.x

I think @HomerJaySimpson has some merit.


I would also consider raising the minimum require bit rate to connect to 12Mb/s.  This will make it much harder for clients to connect to the AP on the other floor.

Thanks for the suggestion, I am going to give the minimum bitrate approach a try; I had adjusted output power of the 'offending' AP but it seems to have caused trouble in the area it is serving. Thanks for the idea!
Get notified when there are additional replies to this discussion.
Welcome to the Meraki Community!
To start contributing, simply sign in with your Cisco account. If you don't yet have a Cisco account, you can sign up.