Forcing SmartLocks to associate to a specific AP

Here to help

Forcing SmartLocks to associate to a specific AP

Ho Folks,


I have a multi unit residential building.  Each unit is equipped with a smart door-lock and smart thermostat connected to the building's SmartHome Wifi SSID and VLAN.


I'm having some problems with locks jumping their AP associations back and forth between APs, which is really draining the batteries in each smart lock a lot fasther than they should.


Is there a way to force a particular client to only associate with a single AP?

Kind of a big deal

I don't know a way to lock a client to one AP, but you can broadcast the SSID from only a single AP.  Would that work for you?  Maybe you need multiple SSID's in this case like doorlock1 and doorlock2 each on it's own AP.

Meraki Employee

Hi @CWK_Rob the semi-official answer is no.  This is ALWAYS the client's decision, which AP to connect to and when to roam.  Every client of course will have its own unique perspective of the RF environment and make its own decisions accordingly.  Plus every client device will approach such decisions depending on the underlying OS, chipset and driver versions, etc.  So even client devices from the same manufacturer, but perhaps with different OS or driver versions, can behave differently for how they associate and roam.  Very client dependent and lots of variables, not to mention the actual RF in your residential building, which can literally change from minute to minute based on doors opening/closing, people moving around, etc.  


If these are the only clients connecting, you can make some adjustments like with radio transmit power, RX-SOP, or minimum bit rate settings to expand/contract the effective coverage cell.  But if other client devices are also connecting for other purposes, proceed with caution when making certain adjustments.  


And as Brandon mentioned, perhaps another possibility is to leverage AP tags and SSID Availability for a separate SSID with fine tuned settings that will encourage the locks to join the AP you intended.  But notice I said "encourage" and not "force".  We can fine tune and encourage the clients to behave the way we want, but cannot force them.  


Kind of a big deal

Following on from @MerakiDave , I would try increasing the minimum bit rate first.  If you are not using 12Mb/s, start by trying to raise it to that. 

Hi @PhilipDAth 

I have been using 24MBps since the building opened

Kind of a big deal

Any firmware updates available for the smart locks?

Get notified when there are additional replies to this discussion.
Welcome to the Meraki Community!
To start contributing, simply sign in with your Cisco account. If you don't yet have a Cisco account, you can sign up.